Unable to daisy chain the my book world 1tb white bar


#1

I have 2 of these devices. The first one is recognized by both vista and xp machines, and is wired directly to the wireless router. The second one powers on and is connected to the USB of the first, but is not recognized on any computer. The WD mapping software can not find it either.  Is there something i am missing in order to get these to daisy chain?  I have not been able to find the solution on the WD support links or faqs, nor from the internets! Thanks!


#2

Are you saying you have one MyBookWorld connected to the other using USB?

If so, that cannot work.  The USB port is a host only.  That is, like a pc, you can plug other USB devices to it, but it cannot be used to connect the MyBookWorld to any other host device (another MyBookWorld, pc, Mac, USB hub …)

:smiley:


#3

You need to connect the second world book to your wireless router as well using another port on your router.


#4

Thanks for your replies. I’ll stop trying to do that.

Now i tried “daisy chaining” with a standard usb external drive. It is a My Book Premium.   I plugged this USB drive into the back of the MBWE.  I still can not find it.  It is not mapped by WD discovery. And it doesn’t show up under My Computer. (The MBWE is plugged into the router and still recognized.  )  Can you help me to get this USB drive recognized?  Thanks again.


#5

When you connect an external drive to the My Book World Edition, it shows up under your MyBookWorld directory as usb1-1share1. You then have an additional folder.


#6

What does the MBWE web UI say?  Have a look at Basic Mode - Folder Shares.  The USB drive should show up there.  Just to make sure, how was the USB drive formatted?  That is, was it formatted on a Windows pc, a Mac or a Linux pc?

If the web UI doesn’t show it, you won’t see it anywhere else either.

:smiley:


#7

I have a Seagate USB external drive connected to my World Edition drive and it shows up on both my MacBook Pro and my Windows 7 PC. It defaulted as “usb1-1share1” on my MacBook and as “10.0.1.6” on my PC. I’m sure I can rename them. I’m using an Airport Extreme router which is assigning the name 10.0.1.6 to the USB drive.


#8

Thanks for your continued help. What a great community.

The weird thing is, the USB driveshows up under Advanced Mode/Storage Tab/USB Disks.  It says the status is “good” . It does not show under the Basic Mode - Folder Shares, nor under Advanced Mode/Folder Shares.  I can not see the drive under My Computer via windows.  TheWD discovery program unfortunately doesn’t.

The USB drive has been used only on PC’s (XP and Vista) with no problem, it is ntfs. I don’t know that i ever formatted it out of the box, but it has never been connected to a mac.

Can i add the USB drive manually under Basic Mode/Folder Shares?  I notice there is an add button. Do i need the mac # or ip address?  Is it even possible?  How can i get this drive discovered and accessible? I feel i’m getting closer. Thanks!


#9

it says:

USB Disk 1-1   320GB     WD 3200JS External    Good


#10

When you plug the usb drive into the My Book World usb port, the usb drive essentially becomes a folder under your My Book. If you explore your My Book you’ll see the usb drive.


#11

OK, now I know what the problem most likely is.  If an NTFS formatted drive is unsafely removed and then connected to a Linux system (pc, MyBookWorld or whatever), it will not be auto-mounted by the OS (and as a result, cannot be read).  The fix is to reconnect the drive to a pc, do a safe removal and then reconnect to the Linux system.

  • Connect the USB drive to a Windows pc and make sure you can see files on the drive.  If the files are still not seen, then there is a problem with the USB drive.
  • Use the safe removal utility in the Windows tool tray by left-clicking the green arrow (the tool tray is in the bottom right corner of an XP pc and usually shows icons for audio, network connections, time and date …).  Select “safely remove USB mass storage device - drive [whatever drive letter has been assigned]”.
  • Connect the USB drive to your MyBookWorld and you should now be able to see the USB files on the network

:smiley:


#12

Oh I was so excited to try your suggestion over the weekend NASdude.  I tried plugging it in directly to a pc and safely unmounting it. But when I plugged it back in to the MBWE it still did not come up.  I also tried it with a second USB external drive and got the same business.

I can see it in Advanced mode/Storage/USB disks but it doesnt appear as a drive under My Computer, nor as a folder inside the MBWE folder, BlakJava.  

both of the USB drives work when plugging them into a pc, but I really want to daisy chain them to the MBWE.

Are there any UI settings to tweak ? A firewall problem?  Thanks for any adivce.


#13

This is exactly the problem I have been trying to solve all weekend!  No luck.

I first got the MyBook (MB) attached to a PC and copied some files on it.  I then attached it to MyBookWorld Edition (MBWE) to see if I could see it as either a folder under MBWE or as a new drive…but nothing.  Neither.  

I can attach the MB to a MacBookPro and have no problem seeing the content.  Same on a PC.

But I can’t figure out how to daisychain the MB to the MBWE via the USB port and see/use it.

When accessing the MBWE UI…I can’t see the drive at all.  I used to see the Download and Public folders…but now they show a red x next to them…yet they are completely accessible.  So I’m not sure what that means???

I have even tried to pay for the answer through justanswer.com - to no avail.  

I will be watching this thread with interest…and then likely returning the MyBook Essential drive if I can’t get it noticed off the MBWE.

Any guidance is most appreciated!  

Ash


#14

I believe I have a solution. Doing a little searching I came across this great site. This is not endorsed by WD so use with caution, if the mods don’t delete this post first. http   ://mybookworld.wikidot.com/ntfs take away the spaces.  It tells us that the world book does not recognize the ntfs file system natively.  You must edit some code.  I will try this as well.


#15

audiophonicshz wrote:

I believe I have a solution. Doing a little searching I came across this great site. This is not endorsed by WD so use with caution, if the mods don’t delete this post first. http   ://mybookworld.wikidot.com/ntfs take away the spaces.  It tells us that the world book does not recognize the ntfs file system natively.  You must edit some code.  I will try this as well.

That article is for an earlier version of the firmware that doesn’t support NTFS. The newest firmware version does support NTFS, so those instructions aren’t necessary. I’m not sure why this isn’t working. My NTFS USB drive works just fine.

When you browse to the MBWE, what shares do you see? Are you using Windows or a Mac?


#16

I was so excited to discover this thread.   I have the exact same daisy chain problem.    Here is my configuration:

  • 8TB  WD ShareSpace Raid5 drive.    This is similar to the WorldBook drive.

  • 250GB  WD MyBook USB drive.   This one is NTFS formatted.

  • Note, both drives are Western Digitals

I am trying to backup my 250GB USB drive with about 2.5M files to my 8TB WD ShareSpace drive.   Since I am unable to daisy chain the USB drive to the ShareSpace drive, I had to connect the USB to my laptop to copy the USB files to the ShareSpace drive.   The problem is that the copy process becomes extremely slow (down to 500bytes / sec) when it has to deal with a large number of files.    My hope was the daily chain of the source USB drive to the destination ShareSpace drive, the file transfer can be ran directly between the two drives without having the files flowing through the PC.

Similarly to the situation in the original post, the USB drive is accessible through either my Windows XP and Windows Vista laptop but it is not accessible when daisy chain with the WD ShareSpace drive.   The USB drive is detected by the ShareSpace drive and with a “good status” on the WD Storage Manager software.

I talked to WD level-2 (or senior) support.    Unfortunately, he was not able to give me a solution.    He did give me several solutions that are equivalent to  no-solution.   His solutions were:

1.  Reformat the USB drive.   This is not an option given that I am unable to back up the data on the USB drive 1st.  

2.  Copy the data from the USB drive to the laptop then copy the same data from the laptop to the WD-ShareSpace drive.   I don’t know what that is going to solve - other than copying something twice.   Furthermore, I don’t have 250GB of free space on my laptop.   

Given the following facts:

   1. I am not the only person experience this problem,

   2. The USB drive is formatted with a well known format (i.e… NTFS)

   3. The PC operating system is a well known operating system (Windows XP Professional)

I think it has something to do with WD software.  

Please let me know of any work around.   In the meantime, I am going back to WD Support and push for a solution.    The current no-solution from WD is not acceptable.