Unable to Create Raid

I recently purchased 2 WD Elements 2.5 TB drives, and I am running OSX Lion. I have repeated tried to create a raid, and I get this error: 

POSIX reports: The operation couldn’t be completed. Operation not permitted. 

I am using DiskUtility. I have tried mirrored, striped, and concatenated raid types. I have also tried extended journaled, extended case sensitive journaled, and FAT format types. 

I’ve read some post that suggest you cannot use WD external drives for a raid? I am looking for help in getting this working. I prefer a mirrored raid for backups in case one drive goes out. I am using this for storing family photos, ect.


Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Did you format the drive before setting the RAID configuration? 

Try formatting the drive on MAC OS X Extended Journaled and then try to configure the RAID.

I tried all of this before I posted.  I think it is a limitation with the drive or OS.  I can write to the drive when it is not a raid, so I do not think it is a limitation of Lion being able to manage a drive of this site.  

Well the drive should work on Raid, if seen different capacity drives working just fine in the same setup. 

I will suggest to check on the apple forums to see if any one else got this error msg.