Unable to create MyCloud.com account with Hotmail email

It seems that I cannot use any Microsoft (outlook or hotmail) account to create an account for MyCloud.com. The emails simply do not come through, but work perfectly fine on Gmail.

Is this a known issue? I have nothing blocking the emails that I have set and they aren’t being filtered into Spam.

Thanks

1 Like

even if you managed to create a Hotmail account … there will be other issues

Apologies for taking so long to reply - my issue isn’t sharing links, its creating an account.

When I create a user on my NAS, I can put in an email or get a code. When I put any hotmail or outlook emails in that box, they don’t receive an email, but my Gmail account does.

I’m having exactly the same issue. It works with a work email, but doesn’t recognise mine or my wife’s hotmail. It’s so frustrating.

1 Like

1000% correct. Hotmail isn’t working for me either. 2 accounts have gmail and no problem at all setting up their accounts. This new person already has a mycloud account for work so she can’t use that email. Guess what. Her 2nd email is hotmail.

Please WD, figure this out!

I’m getting the same issue. Does anyone know the fix?

I don’t think there is anything we can do, it’ll be down to WD to sort it with Hotmail. We’ll have to stick to using anything other than Microsoft emails annoyingly! Would be nice to have some feedback from WD themselves.

Same issue here - spent hours trying to figure it out - never got an activation email from wd when attempting to register using hotmail - then it worked fine with gmail :confused:

Same issue. Why didn’t WD address this? So frustrating.