Unable to create media library on read only storage


#1

Recently bought a WDTV LIve and well pleased except when i plug in my Samsung YP-U3J Flash media mp3 player - i get the above message,and although it only has music on it,when i select the music option and local usb drives,i actually displays the camera logo,and the above message.

When i access via settings to look through the folders,i can see all the folders,including the music one,but it fails to navigate down into it and just repeats the above message.

Is this device incompatible with the WDTV or is there a way around it ?


#2

It depends on how the device is read.  You should plug it into your computer and see if the computer sees it as just a mass storage device.  If it doesn’t, or if the pc requires software or drivers to see it, then the WD TV won’t see it either.  On the flip side, there still may be compatibility issues with the WD TV seeing it. 


#3

I’ve just bought WD TV Live and My Passport SE.

Copied a lot of movies to the HD, and when plugged it to the WD TV, it scans the unity and after this process show the message “Unable to create media library. Pelase check your storage setting”. I’ve already tried to remove the drive security password, but it didn’t work either.

When plugged to the PC, I can see the .wdtv folder in drive’s root directory, which is the same directory wd tv created in my pen drive, and seems to be the media library database.

WD TV is updated to the last version of firmware.

Any hints?

Thanks in advance.


#4

I solved it by disabling Media LIbrary in WD TV, removing directory .wd-tv from My Passport, then plugging it again and later enabling Media Library option. This time WD TV was able to create the library.