Unable to copy files from WD Cloud Device to my PC folders

Have anyone experrienced issues on copying files from WD Cloud device  and pasting them on PC (and or Macbook)?

I am trying to check whether this is a problem caused by my personal network or its a community wide issue. I did not have this issue when I first bought and setup  the WD Cloud device (3TB) about 6 months ago. I suspect the WD latest  software updates maybe causing this.

The issue: 

I can copy the files on the WD Cloud Device and paste it in any folders in the WD Cloud device. However, I cannot paste it outside the WD Cloud Device folders such as the folders on my PCs, my macbook etc. 

I have also updated the WD cloud interface software of all my connecting devices (PC with Win 8, PC with win 7, Macbk Air with OS X Yosemite, Ipad with IOS 8) just to be sure that it’s not due to using the old  interface software. My WD Cloud is also updated with the latest version. The psate issue is still there. 

I have contacted WD and they recommended that i try (a) reset and (b) system restore on my WD Cloud device. I tried both and the same problem still exist.

Any comments, experience or suggestions from the WD Community?

1 Like

Have you tried the 4/40 second reset? Unplug the Wd My Cloud -> Hold the reset button in and plug in the Wd My Cloud -> Hold the reset button for 40 seconds before releasing. You almost need to be a contortionist to accomplish this … but it has worked for me.

Is this LAN or remote? if on LAN file explorer / finder is much better for most operations the the WD apps

Thank you for your suggestion.  I have just tried it and unfortunately the problem is still there i.e. unable to paste my copied file of my WD Cloud device to my desktop PC.

I am accessing my WD Cloud device on my home (internal) network. I have not tried to access by remote (i.e. outside my home network). Same problem on both wired lan and wireless lan i.e. unable to paste my copied file from my WD Cloud device to any of my PCs (desktop, mackbook, laptops etc).

I have just resetted my router and tried it again. Unfortunatlythe problem still exists. Any suggestions?

What error prompt you’re getting when trying to paste? Access denied? Screenshots would help, both mac and win (I’m no mac person). Upload the screenshots elsewhere as mods need to approve them first if uploaded here.

If it’s access issue, to cut the chase go to the wd dashboard shares tab, click on the share that is having the issue, toggle all the user’s access off then full. Due to the inconsistently slow APIs, do this slowly one user at a time. When all done logoff your pc/mac account then relogin and try again from the finder/explorer. If you know linux, this can be quickly accomplished via ssh.

Unfortunately, this is not an access issue. I can copy the files from my WD Cloud Device, but when I tried to paste it on my PC (or for that matter any of my devices such as laptop, Macbook etc), the paste icon is grayed out (i.e. not available).

Access to my device has all been set to “full access”  so its not an an access issue.

I can open and edit  the files on my WD Cloud Device and then save it to my PC (this is OK) but I cannot do a paste.

what are you using to do the copy?

Copy by mouse - right click to copy and right click to paste.

Please first try to copy & paste remotely. Do this via mobile app on mobile network and also via wd2go.com remotely. 

It is quite strange that you can paste from PC/Mac into the nas but not from nas to your PC/Mac.

WD Support staff (Nathalie) from China Office called and assisted me, and educated me on this issue. The matter is solved and closed. Thank you WD Support Team

Basically, if you are using the WD application software (like I did) to access the WD Cloud Device, you cannot copy using the ‘copy and paste’ with the mouse’s right click. You need to open both folders (WD Cloud and the PC) and drag the file across from the WD Cloud folder to the PC folder. 

If you are accessing the WD Cloud Device directly through the local PC Network, then copy and paste using the mouse right click will work.

Thanks to all for the inputs/suggestions.