Unable to connect to Netflix

Anyone else having this issue? Started last night (was on 3.09.18) so this morning I upograded to 3.10 but still no joy. All other onlne services working fine. Just Netflix.



I just tried this - unfortunately it did not work either. It did deactivate my device for Netflix however. But I am still getting the unable to connect you to netflix. Odd as all other online services are working just fine.

  1. Open Netflix on the Live Plus.  Wait for the error message.
  2. Press the following on the remote: UP, UP, DOWN, DOWN, LEFT, RIGHT, LEFT, RIGHT, UP, UP, UP, UP then ENTER.
  3. Confirm deactivation.
  4. Exit Netflix.
  5. Restart Netflix.  It will prompt you to activate your unit on the Netflix website.

I even tried restarting the device.


Have you tried talking to Netflix.

My live Hub is having the same issue.

Upgraded to 3.10 on Wed. - 2/27

It worked last night.  - 2/28 

this morning nothing it gives the message unable to connect to netflix try again or exit

pandora and You Tube work  - so it’s not the connection

i tried netflix on my pc… it’s ok too… 

I posted in the Live Streaming branch as well.  there are many more people there having the same issue. 

has to be the WD Live Hub.


Same here. Netflix stopped around 11pm (02/28/13) while I was browsing my queue, then unable to connect. Firmware version was 3.10 then rolled back to 3.0.6, no joy.

Same problem here.

Netflix diagnostic info ( http://support.netflix.com/en/node/461)) reports SSL handshake failure while connecting to https://secure.netflix.com. Interestingly, netflix has update certificates today (Mar, 1st).

I am afraid that we should wait for WD to release an update to Netflix app to solve this issue! ::angry:


Problem seems to be solved since netflix rolled back to previous certificate expiring on 05/09/2013.


So does this mean that in fact it was something to do with Netflix and everything is working again.

It;s Netflix’s end. but I’m staying with the old fw for other issues.