Unable to connect to Netflix in last 3 days

On the last 3 days, my 2  WDTV streaming Live and 1 Live + can’t connect to Netflix. “Unable to connect. Please try again”…You tube or other apps are fine.

At first I thought problem from NF, chatted with them last 2 days. We had been doing everything we could: NF deactivated then activate NF. I reset router. Unplugged the WDTV(s), resting wdtv to lower resolution, anything I can think of… no luck

I though when I came here, you guys here would have the same problems (not that I wanted to see  smile.gif

I have 1 Roku and connects to Netflix fine. Also no problem when playing NF on pc.

I have been using these units with NF for years.  I have att unverse 12mp.

Any helps?

did you at least try a factory reset

netflix has been on the last few days in a row here

also is it netflix usa or canada

could be some geolocation issue not being correctly determined

Yes, I did factory reset on all three.   The strane thing is Roku and PC work fine

I live in US

I’ve had the same issue over the past few days. Can connect to other web services but not Netflix, also in US

Same thing here. I updated to latest firmware a few days ago, and now I can not connect with the Netflix app. I can connect via laptop on same connection, which is also AT&T 12Mb, and other WDTV services connect fine.

I tried rolling back to the two previous firmware versions, and the same problem still exists. I have never used the reset button on the bottom of the unit. Would this be a case where it might be necessary? Or is this a problem on Netflix’s end? This is quite frustrating, as Netflix accounts for at least 75% of my WDTV usage, and the reason I bought the box in the first place.

I am having the same problem on my WD LIve Hub. All other online seervices working fine, no joy with Netflix.


I seem to be having this problem as well. I used it just last night, but it’s not working as of this morning.

I did the button combo as instructed by this help page, as well asdeactivating all of my devices from the account page. Other internet services (Pandora, Youtube) are still working. Verizon FIOS in NJ.

I am having the same issue with netflix

upgraded to latest firmware Wednesday the 27th… worked last night the 28th for an hour.

now this a.m. the boys wanted to watch a transformers episode on netflix.

I get the message it can’t connect… try again or exit. 

pandora and You tube work fine. 


Ugh, this is really frustrated.

Talked with NF 3 days straight, no luck.  Last night I told them that I heard NF goes out depends on geography.  CSR responded it is not true.  Told me to call my ISP to make sure I get the connection. I told him that my internet, phone (I use Ooma)… are fine.  But he insisted.  I think thay have no solution.

I called my ISP last night for the heck of it.  As expected, nothing out of ordinary.

Now, if the NF is good (I can tream on Roku).  Internet is fine.  What left: WDTV.

Man, the last 3 days is headache. 

mines back working as from about 14:00pm uk time :slight_smile:

It’s working now. Actually works a lot better than before, faster loading.

So nothing to do with the new firmware or the player (in this case)

****mines back working as from about 14:00pm uk time

After seing this post, gave me hope :).  Got home after work and check it.  NF is back :slight_smile:

I don’t  think it’s because of firmware.  My 3 boxes still asked for update.  Just did after NF is back

Darn, happy too soon.  Problem is back.  Can’t connect again :slight_smile:

I really don’t understand why.  My Roku, dvd player, and pc are streaming Netflix fine but not my darn 3 boxes Live.  WD please help because I about to smash those boxes.