Unable to connect to mycloud dashboard

It was working earlier this week but it just randomly disconnected. I can see it connected when I log into my router but I can’t connect via Windows nor can I connect when typing in the my cloud IP address for the dashboard.

Logging into os5. mycloud. com/cloud/shares says that the device is offline.

I tried resetting the box, depowering/repowering it, nothing works.

Does no one know anything? Should I just throw away this mycloud?

What specific My Cloud unit do you have?
Are you running OS3 (v4.x/v2.x) firmware or OS5 (v5.x) firmware? This subforum where you initially posted your issue discusses OS3 firmware issues. There is a separate subforum section for OS5 firmware issues. (https://community.wd.com/c/os5/252)
What color is the front LED? Blue or some other color?
Have you tried a 4 second reset? What about a 40 second reset? (How to Reset a My Cloud Device)
What other troubleshooting steps have you tried?

Thanks for your reply

I updated the firmware about a month ago to v5.

The blue light is on on the unit. I’ve tried restarting it by using a paper clip on the rest button, both the 4 second with the power on and 40 second when I plug power into it.

I’ve reset my router, used multiple browsers/computers/OSs to access my mycloud IP address for the dashboard. None of these have worked; The dashboard page never loads.

When the mycloud is unplugged, however, the page at least gives an error saying that the site can’t be reached. But when it’s connected it just spins indefinitely.

You may want to search through the OS5 subforum then to see if there are similar issues to yours. More than a few are having indexing issues with OS5 that renders their units inaccessible including the inability to access the My Cloud Dashboard.

And see if there are any WD knowledge base articles that are similar to your issue at the following link::

My Cloud OS 5: Online User Guide and Solutions