Unable to connect to Device

Firstly, apologies for the rudimentary nature of this post; I am far from a technowizard so appreciate all advice on offer but if it could be as simple as you can make it, that would be great!!

I bought myself a WD My Cloud storage last month in the UK and I have just moved to Australia.

Put everything on to the Cloud at home in the UK from various sources via my laptop with no problems at all, very easy.

Now in Australia with the same laptop I cannot tap into the device in the UK: 

  • via the Ap I have on my desktop an error message comes up simply with “can’t connect to this device”

  • via the website and can log in but when I click onto “my device” I am told that the webpage can not load “safari can’t open the page”

Any help more than welcome; I have no idea.

Thank you!


Take a look at this link. Hope it helps.


Thank you for taking the time to reply.

Unfortunately not massively, mainly as I don’t understand a lot of the terms (UPnP, NAS, UI, etc).

But let’s start at the very begining and work through step by step, if thats OK? I have lodged a support case via WD but am yet to hear anything back - bit disapointing!

Anyway, it worked fine was I was on the same wifi connection, but this i’m not sure on…

  • Making sure Mobile Access is enabled

So if hadn’t checked this was enabled before leaving that wifi connection with my laptop and it is off I will not be able to access anything until I am back on the same wifi to enable it?!

Thanks again

Have you tried accessing your drive through the Dashboard? Once in, you should be able to remotely adjust your settings, in particular the Cloud settings.