Unable to connect to device(My cloud) through windows desktop app


I have purchased my WD my cloud 4TB about 2 weeks ago,installed desktop App on my laptop(windows vista) everything worked very well but 2 days ago when I tried to access via desktop app, I got the message " failed to connect to device " please note the following points:

  • I can see the device in my network , able to copy files on device.

  • Dashbord works fine - Front Panel LED is solid blue

-I can access Dashboard via "WD Quick View " but again "open " option on WD Quick View doesn’t work.

  • I have un-installed and installed App several times , didn’t help.

this is really frustrating, I have spent 2 days to fix this and still struggling.

appriciate yor help


Hi sadeg, welcome to the WD Community. Have you tried doing a system only restore for the My Cloud? Check page 84 of the manual for more information.


Hi Thanks for yor reply

yes I have tried that , didn’t help.

1 Like

Is it possible for you to try installing the desktop app on another PC and test it there? 

I don’t have any other computer to test whether I see same problem in another computer but I am able to view and access through my mobile phone (using mobile App) which is connected to same network router( Wi-Fi), mobile app works.

In that case I recommend you to contact tech support directly, they can help you out.