Unable to backup

I’m trying to backup my My Cloud EX2 to a USB drive that is connected to it. When I go to backup and choose NAS to USB, there are no available folders under source. The window that opens is blank. I can choose a destination, but I cannot initiate the backup without being able to select a source. I was able to create a backup this way with no issues when I first set up the NAS. I’ve tried rebooting the EX2 and ejecting and reconnecting the USB drive but I keep having the same issue. I have firmware ver. 1.02.08 installed. Anyone know how to fix this?


Review the steps in page #67 of the user manual.


I’ve tried that, but under step 3, when I click the browse button next to source, the window that used to open and allow me to choose the source is now blank. There are no sources available to select, and because of that I cannot proceed to create the backup.

Did you find a solution to your problem?

(I have the same problem, there are no sources to select!)

No, I did not. Still having the same issue…

I think that the problem is solved now. At least I can see the source folders and register a backup job.  What I did was to perform a system restore, as described at page 126 in the manual. At first I tried tthe reset button on the back of the NAS, but that didn’t fix it. After the restore I had to enter all users and other personal parameters again, but all shares and data were saved. So now I am feeling much better than yesterday. (But I haven’t started the backup job yet. Perhaps I have only just entered another level of problems…)

Thanks for the suggestion.  The factory reset worked for me, too.  


Never mind, they disappeared again.  This is starting to get annoying…

I deleted a share I wasn’t using anymore. After that, the backup feature started working normally again. I don’t know if the issue was the number of shares I had, but this seems to be resolved now.

In my case the USB copy failure is a result of the WD EX2 not detecting the USB device when the unit starts up. It seems as though the unit can’t load the right drivers (this can be verified by starting ssh and using the dmesg command). if a USB 3.0 device is connected when the unit starts up. If a USB 2.0 device is connected (and no USB 3.0 device) then the USB will be visible. Once the unit has started up, plugging the USB 3.0 device will usually (but not always) work.

Unfortunately I don’t know of any easy fix for this. I amsure a firmware update would be required.

Was unable to backup with backup to USB: status Cancel after starting job. The suggestion in this forum to set system to factory settings worked for me. A little weird of WD that they do not communicate before installation: a lot of things you have to redo. Thanks for the suggestion; I am happy!