Unable to back up files to My Passport because there is not enough space


#1

I’m having the same problem as several folks have previously mentioned, and I don’t see a solution.

I got a 4TB WD USB3 drive to back up an internal 4TB drive. The internal drive is about half full. I installed WD Backup included with the new drive, but it won’t back up to this drive. It says “Unable to back up files to My Passport because there is not enough space.”

What I have tried so far:

Check for updates to the WD Backup app. I have the most current version.

Reinstall the WD Backup app.

Check that the external drive is formatted NTFS. And I have since reformatted it multiple times using the WD instructions posted previously just to be sure. Still no luck, I still get the same message.

I’m also backing up my user folder to a different WD drive using the same app, and that’s working just fine. It just doesn’t like this 4TB drive.

Windows 10 Pro version 1607 build 17393.1198
WD Backup version 1.8.6312.2156
Drive: WDBYFT0040BWT-0A

Windows reports free space on drive: 4,000,388,874,240 bytes / 3.63 TB
Windows reports used space on drive I’m trying to back up: 2.04 TB


#2

Hello,

Try running a diagnostic on the drive using WD DLG.

Data Lifeguard Diagnostic for Windows

If it passes all the tests then I recommend you contact support for assistance.


#3

Thanks. It passed those tests (I ran the short test). To try something different I deleted the drive with that tool, reformatted it with WD Drive Utilities included with the drive, and tried again. Same thing. Must be a bug in WD Backup.


#4

I created a support case but have not received any emails or seen any response to it.


#5

Going over the logs I think I’ve found the bug. When WD Backup does a backup, it checks that the destination drive has at least twice as much space as the incremental changes. If not, it wants to prune the oldest backups. The bug is that when it does the first backup it also makes this check, and if the source drive is over half full (and the source and backup drives are of similar size) it thinks there’s not enough space on the destination drive, so it tries to prune. But there’s nothing to prune because the drive is empty. Crash and burn.

Here’s hoping for a quick bug fix release.

A section of the log:

6/14/2017 11:39:26 AM Severity=INFORMATION Message=Message: (5) Computing required space for the next backup...
6/14/2017 11:40:17 AM Severity=INFORMATION Message=Message: (5) ...Done computing required space for the next backup
6/14/2017 11:40:17 AM Severity=INFORMATION Message=Message: (5) TwiceOfChangeSz:4373857420812, TenPctTotalCapacity:400061731225
6/14/2017 11:40:17 AM Severity=INFORMATION Message=Message: (5) TwiceOfChangeSz:4000617312256, TenPctTotalCapacity:400061731225, target:4000617312256, freespace: 4000256221184, spacefreedup: 0
6/14/2017 11:40:17 AM Severity=INFORMATION Message=Message: (5) More pruning needed
6/14/2017 11:40:17 AM Severity=INFORMATION Message=Message: (5) Need to start pruning, disk is close to full
6/14/2017 11:40:17 AM Severity=INFORMATION Message=Message: (5) Free storage space is 4000256221184, need to prune oldest backups first
6/14/2017 11:40:17 AM Severity=INFORMATION Message=Message: (3) Could not prune older backups that were filling up the disk space:21
6/14/2017 11:40:17 AM Severity=INFORMATION Message=Message: (3) Do not have enough WD Backup data to clean, cannot proceed with backup

#6

Western Digital Support, how about some help here?
I’ve got the same problem. Just bought the 4TB passport and attempted backup 2.12TB. After a few minutes of “preparing backup,” the error popped up about not enough space. I reduced the folders for backup down to 1TB and then the backup started. This is a rather significant bug for a device intended to be used as a backup.


#7

I opened a case with WD but was just given the same direction as above. When the disk checked out ok, they advised that I should use Window’s backup software instead of WD Backup. When I said the backup built in to Windows was not usable for my purposes, they decided the drive was defective (???) and offered to replace it.

In the mean time I’ve been searching for other possible answers, and I see several people have my problem, several others have a similar problem where backups work for a while, but eventually stop with similar errors in the logs. Overall I get the impression that WD Backup is pretty buggy and not at all supported by WD. I’m looking at other options.


#8

I have the same problem - my drive has 2TB free, and I’m trying to backup 1.2TB.

Just abandoned this piece of ■■■■ software.


#9

Well okay. I have the same problem. I tried the same things. Still no solution. Never buying anything from WD again. That’s for sure


#10

Any solution to this??? I’m getting the same error: unable to backup files to my passport because there is not enough space. I still get this error after uninstalling all of the software and formatting the drive. Unhappy Camper


#11

Just got the same 4TB drive to back up 2TB of data. Same problem. WD Backup is useless software.


#12

Any solution to this? Completely wiped my drive and I’m still getting this issue. This drive is new. I’ll never buy another WD product.


#13

I have read this stream of emails and now have become depressed because my backup has not worked for 6 months after working flawlessly for about a year. I thought it was something that I had done and tried every conceivable fix and nothing worked. Thus, I decided to see if there was a fix and was flabbergasted to see others with the same problem and WD had not responded whatsoever with a resolution. This product had come highly recommended at an Apple authorized outlet and now I will go back and tell them that it was a poor recommendation and others are having similar problems. I understand when products don’t work, but when a company doesn’t try whatsoever to support their users others need to be informed. Thanks for the countless hours of hassle and uncertainty because my files are not properly backed up!!


#14

If you’ve got a mac you’re better off using Time Machine, or if you want a bootable clone, Carbon Copy Cloner or Super Duper. The WD drives are generally good but in trying to get support for this it was clear they don’t support their backup software at all. They just tell you to use someone else’s backup software as soon as you start having problems.