Unable to Activate WD SmartWare

Purchased several My Books.  I purchased WD SmartWare upgrade to Pro.  I then received an activation

code via email.  I tried to activate, but kept getting an error saying it cannot activate now and to try again later.

The problem persisted so I called support.  They tell me that their activation server is down and to try again

in 24 hours.

24 hours later I tried again.  Same problem.  Anybody have any information regarding this?



Yes - Many of us are having the problem activating WD Smartware Pro 2.3.0. 

An associated problem is that once activated…the next day or anytime later … Activation is lost and attempts to reactivate frequently result in a “Try Again” error.

See related problem in this forum entitled “WD Smartware Pro Now Asking me to Activate -AGAIN”. It has 6 pages and  almost 800 views. 

For four long weeks - WD has stated either via this forum or directly by WD Support is that they are aware of the problem.  Many case numbers are “open”. 

My recommendation is to not use the software as your primary backup running on an automatic schedule because at this point -  it is unreliable.  Maybe a fix will be available soon  ???