Unable To Access WD_Backup share on MacBookPro version 10.9 or MacMini version 1010

I have an old MyBook World Edition NAS-Model WD10000H1NC, which has been working perfectly up until now.

I have recently moved and set up the NAS, I cannot access the backup share from either of my Apple devices.

Both machines see the share, but cannot connect. The public and download share work fine. I checked for firmware, but was up to date. I reloaded wd-anywhere; still no good. I reset the drive to factory defualt throught the network manager and still no change. Network manager reports that the drive and volumes are good. Whenever I click on the connect as button, nothing happens. Has anyone had this problem before and if so, how did they fix it. I don’t want to buy a new system, as I don’t think there is any thing wrong with my existing drive.

Hi coemgen57, as a troubleshooting step, have you tried connecting the My Book World directly to the Mac? You can click on the link below to review the steps on how to map a network drive. If the problem continues I recommend you to contact tech support directly. 

How to map a WD network drive on a Mac


I tried that. Instead of paying for support for such an old drive, I removed the hard drive from the unit and put it into an enclosure. I hung it off of the USB port on my airport extreme. Solution taken care of.