Unable to access Transmission using direct link. Login required to dashboard first

I am unable to access Transmission using a direct link like myip/apps/transmission/web/transmission.html.

Each time I am required to log into the dashboard at myip, get redirected to the custom https url (not desired at all, many users specifically requesting to be able to turn this off), navigate to apps, click transmission, click configure, and then it opens in a new tab. Even after all that if I refresh the page it requires me to repeat all the previous steps as it times out the session and the https redirect has to be done anew fresh.

There have been multiple threads on this topic, many users commenting the same thing, and all the answers we receive are “this should not happen” and “you can use the direct ip as before” but that isn’t the case.

Can someone from WD please specify a date for a rollout of a fix for this issue? When can we expect a new firmware release that allows us to turn off this https redirect to avoid this problem? When can we access our devices directly to avoid this problem?

I figured it out and posted it over in the Disable HTTPS redirect thread

But here it is in duplicate again for anyone who’s interested:

I too found a way to block this using uBlock Origin, huzzah!

You must have advanced mode turned on in the extension settings and then when you navigate to YourIP for your NAS you configure the settings like this:

Once this is set, using direct links like MyIP/apps/transmission/web/transmission.html works without having to go through the admin panel and navigating to the app configure first too! Great success!