Unable to access to my NAS with Windows


#1

Hi,

First of all, sorry for my bad english.

Then, I’ve another problem (more than my english level).

I upgraded samba on my MyBook Live, and now it’s impossible to access to my files with my Windows Seven’s explorer.

I think I loose some important configurations of the smb.conf file in /etc/samba/

If someone can show me the content of this file, with a particular attention of no copying sensitive data, it may help me.

Otherwise, if someone have another idea, I’ve not only upgraded samba…

PS: I can easily access to the web pannel, to the ssh and WD Quick View recognize as well my Drive. Just the explorer ask me a password to access to the Public folder, and I tried all my pass, even a desactivation of password.


#2

Hey,

I tried this morning with my Internet Tablet on android, and I could browse with the upnp but not with the smb protocole. So I really think that my samba configuration is bad.

Please, show me your version.

Thanks


#3

Hi.

Here is my smb.conf (My Book Live with firmware 01.02.03) - http://paste2.org/p/1236148


#4

Hey,

Thank you very much for your answer and your fastness.

I repared my samba access with this file.

However, I tried to install OpenVPN, I succed but it takes so long time for me… And now, I’ve already problems of network configuration on my NAS, I’m backing up my data before tried some others ones.

Is there a solution to re-install a MyBook Live if I broke Debian and loose the ssh access?

Something to reset and re-install Debian?

Is there a driver to access to/mount the disk as a USB disk (even if the physical link is ethernet)?

Thanks a lot jazzymood,

DarKChAm.


#5

Nope… THat’s why WD STRONGLY DISCOURAGES people from logging in via SSH and monkeying with the system.

They warn you when you access the SSH enable page, and every time you log in:

SSH provides access to the network device and all its content, only users with advanced computer networking and Linux experience should enable it. Failure to understand the Linux command line interface can result in rendering your network device inoperable.

#6

Hum…

That’s a bad point for WD.

Why don’t they make a restore partition, or a way to install one?

So, I’ve to make it myself…

Thanks.


#7

I believe there IS a restore partition.    I’ve not tried it, but my understanding is that you can do a “RESTORE” to factory defaults and it will restore the partitions and everything (it does warn that it’ll erase everything.)

Give it a try.  At this point, you’ve nothing to lose…