Unable to access the VCD

I have a WD Passport Essential SE (USB 3.0) that had work with no issues for the past 2 mos.  I was just suprised 1 day that I’m no longer able to access the hidden VCD.  I was able to unlock the drive but it won’t show the hidden partition anymore.  I checked Disk Management (OS: Win 7) and had the hidden partition unitialized.  When I try to initialize it, it says its write protected.  So I did check Smartware, entered my password to unlock.  My Passport Essential says - No writable WD Smartware partition found. :cry:  I thought it was the password protection that keeps me from accessing the partition so I did try to disable the security but when I tried to, it says that my password is incorrect!! 

I did find a KB article from wdc support which requires me to update my firmware using the apollo updater but it also fails to read my ext hdd.



The majority of the times when a drive is write protected is better to replace the drive than doing a lot of troubleshooting, however test the drive using TestDisk that software may solve that problem.-

I’m running testdisk now…what particular procedure in testdisk do I have to perform to resolve my issue?  Thanks for the quick reply.

Disk /dev/sdb - 750GB /698 GiB - CHS 91197 255 63

Partition: Read Error

No partitions were found after analysing was finished.  Do I have to replace this drive or are there other solutions? 

Sounds like a bad drive based off of the behavior you are seeing.

What happened?  Did you replace the drive, or did test disk help?  Cause usually when it says there’s no writable partition found, that can mean that the partition got corrupted.

I’m not sure what happened but after trying to run testdisk from a linux environment, I plugged it in to a windows machine and voila, was able to access it again.  I don’t how it worked but was thankful it did.  But i’m never gonna let this thing happen again, so I’ve removed smartware!  Thanks to everyone who tried to help.

that’s problably because testdisk restored the partition.  you should give ricardodegracia an accepted solution, or at least a kudo for recommending it to you.

Hey, I’m having the very same problem right now and trying to follow your steps to recover.

who are you referring to?