Unable to access symbolic link on My Book Live from Finder MAC OSX 10.8.1

I have My Book Live Duo 6TB, configured with RAID-1 with ssh enabled (i was really happy that my WD using Linux :-)). Using command line with terminal on mac to manage my WD is easier and i dont need to depend on laptop/pc during copying from external HDD (connected to USB port on WD). Simple put it as background process and let she works until finished. Hundreds gigs succesfully transferring to my WD and then i realized that it copied to /DataVolume/shares/ directory. Suprise me when found that  its not able to display on macbook finder explorer, it shows only some directories (user, public, smartware and timemachine).

I thought to be able to access my directories which not ‘physically’ under Public or UserName is simple create symlink, I created symbolic link (ln -s destination_folder link_name) under Public directory. as expected, i able to access symbolic link from command line (when i am in terminal) but unable to access it from Finder. it shows only small file blank icon with symlink name and when i open (double click), it pop-up “The operation can’t be completed because the original item for “Album_Photos” can’t be found.” error.

What I have tried:

  • Set original directory group as ‘share’ and owner as ‘nobody’ (refer to Public directory ownership/group)

  • Configure smb.conf with “unix extensions = no” and do /etc/init.d/samba restart. found some trick related to WDTV.

  • Tried to change symlink permission; but not able to change without error. remain as root:root (own:group)

  • Tried to connect as admin user to WD

  • Tried create symlink under my own user directory

  • Restart My Book Live Duo

But still, I’m not able to access my directories/files with symbolic link.

I will only able to access symbolic link from Finder, if i created symlink under user directory which actually accessing original dir/files in the same owner.

is there something i missed on ownership/group permission? or something else?

here is my list directories:

drwxrwxrw- 19 nobody share 65536 May  3 10:50 from_toshiba
drwxrwxr-x  3 root   share 65536 May  3 18:17 SmartWare
drwxrwxr-x  4 root   share 65536 May  3 22:48 TimeMachine
drwxrwxr-x 10 nobody share 65536 May  3 23:08 tafa
drwxrwxr-x 15 nobody share 65536 May  3 23:09 Public
mydisk:/DataVolume/shares# pwd
/DataVolume/shares

and this is symlink:

lrwxrwxrwx 1 root     root        52 May  3 21:21 Album_Photos -> /DataVolume/shares/from_toshiba/

drwxrwxr-x 3 root     share    65536 Apr 23 19:42 Network Trash Folder
drwxrwxr-x 3 root     share    65536 Apr 23 19:43 Shared Music
drwxrwxr-x 4 root     share    65536 Apr 27 12:34 Shared Pictures
drwxrwxr-x 4 root     share    65536 Apr 27 12:35 Shared Videos
drwxrwxrwx 7 root     share    65536 Apr 23 19:43 Software
drwxrwxr-x 3 root     share    65536 Apr 23 19:42 Temporary Items
mydisk:/DataVolume/shares/Public#

And, this symlink works perfect:

mydisk:/DataVolume/shares/tafa# ll
total 192
drwxrwxr-x 3 root share 65536 Apr 23 20:53 Network Trash Folder
drwxrwxr-x 3 root share 65536 Apr 23 20:53 Temporary Items
lrwxrwxrwx 1 root root      8 May  3 23:07 mytorrent -> torrents
drwxr-sr-x 3 tafa share 65536 Apr 23 21:28 torrents
mydisk:/DataVolume/shares/tafa#

Thanks,

@tafathoni

Samba must be configured explicitly to follow symlinks.

follow symlinks = yes
https://www.samba.org/samba/docs/using_samba/ch08.html

Under certain circumstances, that will require unix extensions to be enabled.

Hi TonyPh12345,

Thanks for your quick response.

I did it,

  • add ‘follow symlinks = yes’ to smb.conf with ‘unix extensions = no’ --> restart samba, result still not able to access symlink

  • add ‘follow symlinks = yes’ to smb.conf with ‘unix extensions = yes’ --> restart samba, result still not able to access symlink

  • after that i tried again add ‘wide link = yes’, but still no luck.

here is my smb.conf after 3 times changed:

mydisk:/etc/samba# cat smb.conf
[global]
  workgroup = tafa
  realm = WORKGROUP
  netbios name = mydisk
  server string = My Book Live Duo Personal Cloud Storage

  include = /etc/samba/smb-global.conf
  include = /etc/samba/smb-global_veto.conf
  include = /etc/samba/overall_share

[share]
  unix extensions = no
  follow symlinks = yes
 wide links = yes
mydisk:/etc/samba#

after that i tried again add ‘wide link = yes’, but still no luck.

I see in smb-global.conf, default for unix extensions set to ‘no’. (i didnt change anything on smb-global.conf).

please advice