Unable to access shares from Gnome Nautilus (Ubuntu installation)


#1

Have multiple shares on my device, some public and some private. I also use a Unbuntu v18.x laptop. The built in file management GUI is Gnome Nautilus. Previously I had been able to browse the shares from Nautilus and to access the shares, both private and public, but I am no longer able to do so.

I had made some changes to the network settings a while back, but I don’t think that I changed anything that would prevent Nautilus from accessing the shares. As a matter of fact, I can access them via the command line. I can mount both public and private shares using samba. I just can’t access them via Nautilus.

There really isn’t much for settings, but can someone suggest a setting that I might have missed or didn’t think that I need, but really do?

Thanks

Daryl


#2

AFAIK, they fixed a few security issues with automatic discovery over the network, hence the issues with nautilus.
I get a connection error with the auto discovered my cloud device, probably the same as you.
I use ‘Other locations’ - Server Address = smb://hostname to access the NAS in Nautilus.


#3

Nautilus can see the nas device, so autodiscovery is working just fine. However, I can’t connect to the nas if I click on it. I get “Unable to Connect” or something like that.

I have manually typed in the command in the server address bar. Nautilus can see the shares if I do that, but I can’t access the private shares with my restricted user(s). None of them work. They all get access denied.

Something with the restricted user ID’s and the private shares. I feel that its something on the NAS because I’ve tried multiple versions of Ubuntu, from v14.x up to v18.10 and I’m having the exact same issues across all versions.

Daryl


#4

Create a user ‘test’ on the NAS.
A private ‘test’ gets created for this user.
In Nautilus, select Other Locations, then ‘Connect to Server’ with smb://mycloudpr4100.
Select Connect.
Select the ‘test’ share and fill in the test user credentials.

The auto discovered MyCloudPR4100 in the Networks list doesn’t work for me: Connection Refused whatever I do.


#5

I did that prior to posting.

I also opened a ticket with support and was politely told that they to not support Linux or Ubuntu. Which is funny because the NAS OS is Linux.

I just remembered that there was a firmware release in January (about the same time I was displaced and had to relocate to my temporary location). I looked up the release notes and see there was a security fix applied

Added brute force attack mitigation

I’m not sure what was fixed, but I’m beginning to think that is the cause of my frustration.

Daryl


#6

It seems your issues are mainly with Nautilus as that is the component failing to mount the shares. A quick google search shows plenty of similar issues.
And I doubt there’s a lot of Nautilus devs browsing this forum… so I’d stick to command line mounts (which works both for nfs and smb) and put them in your /etc/fstab.


#7

No, I don’t think so. I’m pretty confident that its on the NAS side. As I said, this has worked up until recently, then all of a sudden, it stopped work, and it stopped working mid January or so.

I did a lot of google searching, and I wasn’t to successful finding post’s similar to what I’m having issue with. I’m not sure how Nautilus does CIFS mounts. If I can figure that out, I might be able to do better at troubleshooting this issue.

Daryl