Unable to access NAS when it's connected to 2nd adapter

I have the 1st Livewire adapter and my PC connected to my router, and no device is connected to the 1st adapter. I then have WD TV Live and a NAS connected to the 2nd adapter loacted at the other end of the house. Here is the strange problem I run into…

From WD TV Live I can access the NAS but from my PC I can’t even see the NAS. However, if I plug my NAS to the 1st adapter, then both WD TV Live and PC can access it.

The reason I want to have my NAS connected to the 2nd adapter instead the1st one is because that’s the only way I can have WD TV Live stream HD videos from the NAS smoothly.

Any help is appreciated.

more info…

While both WD TV Live and NAS are connected to the 2nd adapter, my router detects both the NAS and WD TV Live as its DHCP clients, but I can’t access NAS admin page or browse its files. Meanwhile I can access the admin page for WD TV Live no problem… what’s going on???

Have you tried connecting the two livewires to the same wall socket? To verify if the same problem happens again.