Unable to access My Book Live Dashboard on OS X 10.7 Lion


Apologies if this issue has already been posted. I’ve searched but can’t find the solution here.

Product: WD My Book Live 2 Tb

OS: 10.7.5 Lion

I have the WD Quick View software (latest version from web) installed but when I try to open the Dashboard, although it opens Safari and pastes in the url, it fails to open the page.

I’ve tried using a different browser (Opera) and typing the following in manually all with no success.




Either the browser opens a blank page or gives me a server error.

I’ve also tried to open the page from an iPad using ios 6 Safari (on the same wifi network) and an Android device using Google Chrome (on same wifi and also via 3 G) with the same results.

I’ve successfully opened the Dashboard in the past but probably almost a year ago when I purchased the My Book Live. i’d just like to add another mobile device to be able to access it but don’t think this is possible without being able to access the Dashboard?

Aside from this issue the My Book Live seems to be working fine. I can access the files and add/delete via Finder with no problems.

Try connecting the my book directly to the Mac and try again, if that doesn’t work try pressing the reset button on the back of the my book for 4 seconds. 


Thanks for the suggestions.

I’ve tried connecting the drive directly to the Mac with no success. I also tried resetting the drive using the reset button (held down for 4 seconds) but that still did not yield the desired result.

I have also:

  1. Tried powering off the drive, holding the reset button and powering it on until the reset occurred;

  2. Powered off/on the drive, router and Mac in various orders;

  3. Checked the latest version of Java was installed on the Mac (it is).

…and still no success.

What was interesting is that if I try to open the dashboard with the router turned off I get an error on the browser saying the address was not contactable (which is expected) and the ‘UI’ bit of the URL http://mybooklive.login/UI/ does not appear. This suggests to me that the connection between the Mac and the drive’s dashboard is being made but for some reason the dashboard itself is not being displayed. I tried looking at the source html for the blank dashboard page and it has a few basic html tags but no content, which might suggest that the dashboard has become corrupted.

It occours to me that it might be a background update to the drive firmware that has borked the dashboard. After further searching I am seeing this happening to other people. Unfortunatley I have no way of finding out if an update occurred.

It seems that the only 2 options I have are:

  1. Use SSH to connect to the drive and reset the config to factory defaults. This won’t work as I hadn’t already enabled SSH on the drive (got this solution from elsewhere on the web)

  2. Buy a replacement drive.

Any thoughts? I was thinking that I could reinstall the dashboard but can’t get to the protected files on the drive (which is what the SSH method does).

Cheers again for all the help.