Unable to access My Book Home Edition 1 TB drive

I am unable to access my external hard drive.  It does not show up in My Computer or under disk storage devices (in Manage My Computer).  The front panel light blinks on and off. _ _I have tried both USB and firewire connections.  The drive does have an ESATA connection also.  The model number is WD10000H1CS-00.  Is there anything I can try to access the files on the drive?  At this point I am willing to open the case.  I am primarily interested in copying the files to another drive and don’t need to continue using this drive.  Any help is most appreciated.  Thanks,


Good day!

I’m new here too, and I’m sorry to hear about your problem. I just wanted to give you a heads-up about posting your e-mail address on message boards; it might not be a good idea to do so due to spammers/bots/hackers/etc. You might want to edit it out.

As for your problem, are you hearing strange noises from the drive? Also, have you noticed if the driver installation for the hard drive was triggered? You might also want to try plugging the drive to another computer.

This is the same problem I have, except that the drive was dropped.  I was able to open and view the files stored when I frantically plugged back in, but now cannot access files. It does show the drive under “My Computer” but will not load and tells me I have to format the drive.  Help - some one, help!

Really sorry to say, but accessing a dropped hard drive (especially when mechanical failure is observed) is something which is sometimes left to chance. You can try to access it on another computer, or keep on trying by unplugging it and plugging it back again. After which, I highly recommend backing up your files. I wish you the best of luck. :slight_smile:


Thanks very much for you advice regarding posting my email address - I had not thought of that and I think you are quite right.  I have edited out the email address.

Regarding the drive - this is not a brand new installation.  I was using the drive for awhile after purchasing it.  At some point the drive was not working properly - my recollection is that it worked sporadically but I am not sure.  I disconnected it and put it on a shelf planning to look into it when I had some time.  I guess now is the time!  I will try it on another computer later.  Let me know if you have any further ideas - and thanks again.


:cry:  Thanks for the reply, and I’m going to try to connect on my old PC.  Would “missing sectors” , as part of the diagnosis, be repairable and would any free download cure this? I’m hoping that nothing drastic happened during the drop and that perhaps I could retrieve something. Again, thank you for replying.

~in the ozone~