Unable to access my book 320 gb drive any more

Hi

 I have a problem with accessing my WD External 320 GB

 hard drive. It worked fine for 3 years with no problems.

 A week ago I was getting it ready to back up to CD’s

 when I started getting an error message saying:

 Windows - Delayed write failed_. M: something below it.

 This message appeared several times as I was moving some

 files to that hard drive. I had 4 partitions on it.

 Now I cannot access it at all. My BIOS sees the drive,

 when I go into control panel,system then hardware I

 see the drive in the disks folder and also in the USB folder

 as a USB MASS Storage drive. It also is seen in the safley

 remove usb icon. It does not show up in disk manager.

 I have rum the USB device viewer program and it show the

 following info on it:

        —===>Device Information<===—
*!*ERROR:  no String Descriptor for index 2!

ConnectionStatus:                 
Current Config Value:              0x01  -> Device Bus Speed: High
Device Address:                    0x02
Open Pipes:                           2

          ===>Endpoint Descriptor<===
bLength:                           0x07
bDescriptorType:                   0x05
bEndpointAddress:                  0x81  -> Direction: IN - EndpointID: 1
bmAttributes:                      0x02  -> Bulk Transfer Type
wMaxPacketSize:                  0x0200 = 0x200 max bytes
bInterval:                         0x00

          ===>Endpoint Descriptor<===
bLength:                           0x07
bDescriptorType:                   0x05
bEndpointAddress:                  0x02  -> Direction: OUT - EndpointID: 2
bmAttributes:                      0x02  -> Bulk Transfer Type
wMaxPacketSize:                  0x0200 = 0x200 max bytes
bInterval:                         0x00

          ===>Device Descriptor<===
bLength:                           0x12
bDescriptorType:                   0x01
bcdUSB:                          0x0200
bDeviceClass:                      0x00  -> This is an Interface Class Defined Device
bDeviceSubClass:                   0x00
bDeviceProtocol:                   0x00
bMaxPacketSize0:                   0x40 = (64) Bytes
idVendor:                        0x1058 = Western Digital Technologies, Inc.
idProduct:                       0x0910
bcdDevice:                       0x0106
iManufacturer:                     0x01
*!*ERROR:  no String Descriptor for index 1!
iProduct:                          0x02
*!*ERROR:  no String Descriptor for index 2!
iSerialNumber:                     0x03
*!*ERROR:  no String Descriptor for index 3!
bNumConfigurations:                0x01

 Am I able to repair this drive with what this info says?

 I would like to save the data that was on this drive.

 Any help is appreciated.

 Don DeJaynes

delayed write fail is usually an indication that the cable is bad, or not correctly connecting.  try another cable, and/or computer to make sure that it’s not the usb port you’re using, either.

1 Like

Thanks Wayne

I tried a different usb cable and got the same results. Also tried it on my laptop and it wouldn’t recognise it either.

I even plugged the power cord into a standard wall outlet but no changes.

I have removed the harddrive itself and hooked it inside my computer to a sata connecter and recieved no results.

It showed up in BIOS and system-device manager under disk drives. It will not show in the disk manager window.

Any other things I could try.

I have run test drive and it doesn’t show up on it either.

I have a feeling I don’t have anymore options left.

Thank you for the quick reply and any other info you can give.

Don