Unable to access device My Book Live. via network or IP

I am unable to access the My Book Live via the network or the Ip. the light is flashing green and the lights are flashing for the ethernet cables.


Have you tried a reset and/or power cycle?

yes I have. it is not showing up for my laptop or my desktop. I have it plugged into a router with an ethernet cable and the lights are flashing green and the light on the front is flashing green.

How did you find the IP? What is the IP? How did you try to connect by IP?

I looked up the IP with a program called Netscan, It shows an IP but no MAC address. It does not show up in the network at all… the light on the front is green

Don’t worry about netscan. The fact that you have a green LED means it is connected to the network, you just need to find the correct IP.

You need to get your IP from your router’s DCHP lease table. Once you get it try two test:

  • Using IE/Chrome/FF, type http://yourdeviceip or That should give you the dashboard
  • Using Windows Explorer, type at the address bar: \\yourdeviceip or \\ That should give you the shares

Edit “yourdeviceip” or “” with your actual IP, these are just samples.

Tried both of those options and all i get is the message “err_connection_timed_out” or ERR_NAME_NOT_RESOLVED.
I was using Chrome

Having same issue. Used to connect via but now nothing.

In explorer mybooklive is visible as a storage device under my pc network. Yet I double click to open and same issue.

Also connect remotely from phone.

This thing is giving me real problems, even though I can still access all the files on the unit from my PC.

I’m having a very similar issue with my Mac computers, even though my PC can access them sometimes. I thought these drive were supposed to allow more than one person to access the drive at the same time… I have two WD My Book Live and one WD My Book Live Duo… No response from ip, file browser, web dashboard, or anything… I have only been able to access the drives from the WD 2 Go app for the PC… and sometimes the WD My Cloud app on Mac… one computer at a time…

I have the same problem, not is working… I lost everthing?? Please help us!

If you have a green LED, first thing is, to find out the IP for MBL. If MBL is set to DHCP, the IP might change once in a while.

Once you find the IP, go back to my earlier post.

Still no solution to this problem?

I have exactly the same problems.

Luckily, I still have a way to access my data: WD My Cloud.

History of this situation:

It has a few months, my MBLD has become slower. It was the HD B that was breaking down.

I bought an HD. My RAID has rebuilt. It was rather slow but this is understandable with this other event:

So, that I finally thought to be quiet, just a few weeks later it was the HD A that was breaking down.

So, again, buy another HD.

This time the rebuilding of the RAID was much faster.

However the very bad surprise of all this is the impossibility to access the data and the dashboard.

Additional info:

  • The MBLD is there in Windows Explorer (from any PC on my network);
  • Also in my router but under another IP address
  • Using this IP address gives a white web page