Unable to access device (0)

Ok, I’ve had enough, and I need some help. But since I know the problem is not on my side, I have no idea what to do.


0 ) I’m using Static IP in router and also in WD My Cloud, that means static DNS server and IP for MAC address in router.

1 ) I open ed the Ports 443 and 80 on router

2 ) My ISP is not blocking port 443 and 80

3 ) wd2go.com is working and it can see my cloud, also android Wd My cloud app can reach the device

4 ) Working well for few days , without any errors

5 ) 5 days passed since last WD My Cloud restart, and out of nowhere This error message comes up in Android:

Unable to access device (0)

6 ) Rushed to wd2go.com website try to login to my device from external network (work):


"The connection fails

Firefox can’t connect to the address:


Okay you can think maybe wd2go.com is not working, or my router is the faulty thing, BUT!


7 ) FTP is working , and I can reach the My cloud via FTP from external network.  (too bad port 21 is blocked at my work, and I have to use 3G to try it out)

8 ) WD My Cloud is working well on local network , without problem (DLNA and SMB Share)

9 ) That must be a router problem, you think, okay, lets check forwardings, IPs, everything is fine , lets do a reboot, maybe something stucked, 1 minutes later, router is connected to the internet, everything is okay, but I still get the same error message. FTP still works, local my cloud still works, everything is okay, except wd2go.com, and that involves the Android/Windows app.

10 ) 2 things are left, wd2go.com is unaccessable because of maintance , or something is fishy with WD My Cloud, one thing left to do, restart WD My Cloud.

11 ) 5 minutes later everything is magically working again, wd2go.com is working, Android / Windows apps are working again, and I can mount my drive from external IP.

Conclusion, the problem is with My Cloud. I did this procedure 4-5 times in the last 2 months, and sooner or later the Cloud feature will just stop working.

And I just can’t restart My Cloud every day, and hope it will work for the rest of the day…

Why did they have to involve something external, why can’t I just reach my device without wd2go.com? :\

Any ideas what else can I try, if the problem is on my side? :\




You said port 21 is blocked at your work…can you port forward i.e. 3021(ot other) to 21 to MyCloud in your router to pass through your work router firewall?

MyCloud mobile apps are not reliable i use ftp client from wan even for stream audio to my phone/tablet.

They depend on something external because there’d be no way to find your device on the internet otherwise. Most people don’t have static WAN IP addresses nor a static DNS name for their external IP. So the WD2go provides the link between them, like dynamic DNS.

Just curious, when you PING your (redacted) wd2go host name, does it resolve to the correct IP address of your router?

But the half of the users do, and they should enable an option for them to use DynDNS + Static IP to reach their device no matter what … since they are adcertising as a cloud device, but we just can’t reach it 24/7…

Only web ports are open, most of the ports are closed, so I can’t just forward 21 to something else.

I used WingFTP and I could reach it from browsers on port 80, I don’t think it is impossible to “ask” my cloud to run a program for webdav access…

Oh it’s a lot less than half… I’d bet less than 1% have static WAN addresses. With my ISP (Verizon) a static IP costs at least $100 per month additional.

But that’s kind of beside the point. It should work whether it’s a static IP or not. Mine is dynamic, and I’ve yet to lose access to my Cloud.

That’s why I’m curious if your name is resolving correctly–to see if it’s a DNS issue or something else.

I have dynamic IP too, and get new IP almost every 24 hours, and It is working for the first 3-4 days, and usually broke after 5-7 days. And I don’t even touch the router, or the WD My Cloud. In fact I wasn’t even home when I lost my access…

This is frustrating, because the My Clouds cloud function is completely useless, if I can’t use it outside my local network…

I’m thinking about getting rid of this and buy a my book live, does that have the same problems? Or is it just the my cloud?

Bullzeye, lots of people on here are having the sam problem including me. It is the cloud connection that gets messed up. It goes from a direct connection to a relay connection for no reason so the wdcloud software doesn’t work. The only way to reconnect is to reboot or turn cloud setting on and off. Until WD fix this obvious bug in the firmware there is nothing we can do apart from keep rebooting. This isobviously useless if you are at work and can’t reboot though.

TonyPh12345 wrote:
Oh it’s a lot less than half… I’d bet less than 1% have static WAN addresses. With my ISP (Verizon) a static IP costs at least $100 per month additional.

But that’s kind of beside the point. It should work whether it’s a static IP or not. Mine is dynamic, and I’ve yet to lose access to my Cloud.

That’s why I’m curious if your name is resolving correctly–to see if it’s a DNS issue or something else.

Tony, are you using the new firmware and have never lost connection to wd20go or the mycloud app when away from home?

Well, v03.01.04-139 is almost two months old, so I don’t know if that’s the new firmware to which you refer, but that’s the version I’m running.

But no, my connection is rock solid.

Wonder what’s different about your set up to the mine and the others who are having the same problem on here. Does this mean it’s not a firmware bug? would love to fix it


I’ve the same problem with the 3TB MyCloud purchased 2 weeks ago. I have a Netgear N300 modem/router with uPNP enabled.   I’ve tried all the various solutions I found in the forums… incuding the “crontab” solution posted by Steve511 (the date.txt file is re-written every minute, but it hasn’t solved the problem).  The Mycloud continues to disconnect from the LAN after a few hours and needs to be plugged out and back in before it reappears.  When it disappears the device is inaccessible through wifi or remote access.  I don’t have a solution, but thanks to everyone who’s been trying to solve this issue.  Highly frustrating and a thumbs down for WD. :angry:

Update:  I turned off the “Drive Sleep” option in the Settings and the device has stayed connected for 6 days continuously.  So, to remain connected I’m currently writing the date+time to a file on the MyCloud every minute (see post by Steve511) AND the “Drive Sleep” function is turned OFF.  [I also checked the more obvious stuff - different LAN cables, forums for the Netgear N300].  The MyCloud works well now but it’s a pity it can’t go into sleep mode, which it would be in for perhaps 90% of the time. 

Well it would make sense in hindsight as after my device sleeps, I cannot see it when I browse for shares to connect to.

I usually connect to a known share first, then when the drive wakes up, I can see the rest of the shares. Optionally I can ssh into it and it would wake up and then again I can see my shares.

In the old days, I use to use a wakeup lan program that sent a signal through port 9 that wakes up my pc and then I connect to that pc via the shared drives.

I should have read this thread before buying this thing. I just got it 2 days ago and I’m already having problems connecting from the outside via apps. While the Photo app works ok the My Cloud App can not connect…Unable to acces device (0). I think the problem isn’t so much with the app nor the device’s network settings but with WD2GO.com I tried to connect to it numerous tmes from different computers and tablets and I get connection errors. If anyone can recomend a FTP client for Android It’ll be greatly appreciated.

Hi VLCloud,

Since the last firmware update the MYCLOUD has been working as advertised and I’ve had no problems.  Until 2 days ago that is. Since Thursday (March 28th) the wd2go.com site seems to be down and as a result there is no remote access. Wireless access works fine.  Yesterday I sent a request to WD Support asking them for an update but they haven’t got back to me yet… today the wd2go.com website is back up and working and remote access has returned…

Hi Dekolan,
You are correct today the wd2go site is back up which confirms my assumption…i didn’t have a problem with the wd photo app but with the mycloud app.

Still down here