Unable to access data on WD Essential My Pasport 500GB - Helpless

I have a unique problem with my western digital my essential portable drive. It was working fine until last week on my windows 7 home edition.
After I upgraded my laptop to windows7 pro I started facing problems. To being with the drive was detected, it asked me for an unlowck password, after unlocking it showed me the drive and the data. But the drive soon disappeared within

few seconds and I had reconnect to see the problem recur. I tried uninstalling the usb drivers and installing them freshly it did not help. Now the situation is so bad that when I connect it shows me the WD Unlock VCD. When I run

unlock.exe and enter the password, it says unlocked but doest show me the drive. If I try to perform any more operations on the drive, the machine hangs. I have tried the following but unable to solve the problem. Do you have


  1. In Device manager > Disk Drives > uninstall drivers, reconnect the drive and windows automatically installs the drivers.
    [outcome]- The problem is not solved

  2. In DiskManagemnt all I see is a small partition of 27 MB called WD Unlock. I changed the Drive letter and tried
    [outcome]- The problem is not solved

  3. Installed WDSmartware updater on my machine (this is a illogical action, but just outof hope)
    [outcome]- The problem is not solved

  4. Went to WD support center, downloaded the latest firmware for the drive and tried to update it onto the drive by running the executible
    [outcome] - the software intallation dialog box says that the drive already has the latest firmware. When I continued installation, it tried to install and came back saying update failure.

  5. Called Western Digital Support
    [outcome] - They say that because windows is detecting the drive, there must be some problem with the disk, it must be corrupt. They suggested that I eceover my data using freeware like photorec, if it fails pay for expect data retrieval

professionals. After that they can replace the harddrive as it was under warranty. This is a bad solution for me as I can’t pay for the expert service

  1. Ran TestDisk a free utility from CGSecurity
    [outcome] - After a full scan it returns with disk read error/error reading sectors

  2. Ran photorec a free data recovery utility from CGSecurity
    [outcome] - After a full scan it returns with disk read error/error reading sectors

  3. Tried on windows XP machine with antivirus disabled
    [outcome]- The problem is not solved

I am almost helpless in getting this resolved. Any ideas please?

sound like typical failure of encrypted drive my friend.

I’m amazed at the amount of words it took you to say the drive does not work :laughing:

The drive is not been recognized… even when showing the virtual cd partition

if the firmware saw the drive then you will be able to use a software to retrieve the data

if you already tried different computer and different cable , replace under warranty