Unable to access Dashboard via Device Name

I am able to access the dashboard via IP address which is DHCP.
But the same when I use the Device Name, it says ERR_NAME_NOT_RESOLVED

Did all the DNS flush using Command Prompt and also assigned DNS address.
Still no use

Since IP address would be changing every time I have to un-mount the drive and re-mount it.

P.S: I do not want to use Static IP.

Since IP address would be changing every time I have to un-mount the drive and re-mount it.

It shouldn’t. It might change IP address if your reboot MyCloud or router, but unmounting the MyCloud from your file system shouldn’t change the IP.

The alternative to Static IP is infinite lease DHCP; that’s what I use. Set it at your router.

Your router ought to be doing the DNS resolution, so maybe a re-boot of that will resolve your problem.

The IP address should NOT be changing when you “unmount” and or "mount a “drive”. Where the IP address “might” change is when either the router or the My Cloud is power cycled.

Not sure why you don’t want to use a Static IP as it tends to solve the problem of the IP address being reassigned. One can set the static IP either in the router OR in the My Cloud, or as the previous poster indicates change the DHCP server’s “lease timeout” period to infinite or never expire.

If one isn’t using a Static IP then the DNS should be being pulled from the router when it hands out the IP Address to the My Cloud. Like the previouis poster indicated power off both the router and the My Cloud. Wait a few minutes, then power on the router and wait for the router to finish booting up and enter an online state. Then power on the My Cloud and wait till the front LED turns solid blue. Then attempt to access the My Cloud Dashboard.


When I meant IP address changes, its when Router turns off and on itself.

And wrt url http://wdmycloud/ which is my device name (wdmycloud)
its accessible via my desktop which is connected to My Cloud via ethernet cable

But when trying to access it via wifi using my laptop, I am getting the above error

Have switched off and turned on the router/WD My cloud, still the same.

I would suggest that it’s a problem with your laptop, then, and nothing to do with the MyCloud. Check to see what DNS server your PC is using, and make sure your laptop is using the same server.

Did you try our suggestion of fixing the DHCP IP address using your router’s UI?