Unable to access Dashboard/ Public or Shares


I’ve read all other messages on this subject but not seen any answers to overcome the problem.

I cannot access the dashboard from any browseer, have tried three. I’ve restarted by Mac, router and MyBookLive (2TB), and restored the drive by inserting something in the hole in the back. I don’t have SSH access as I didn’t set this. I cannot access through remote devices, iPhone or iPad (Remote Access Disabled by the same fault) using the App. The drive and shared drives show up in folder lists on my Mac but always end with ‘connection failed’ when tried.

I CAN get to the data through Twonky Media Server on any browser on my Mac and devices, and can access through my DLNA TVs.

Can anyone advise please, am I destined to never be able to get back on through Dashboard? Am I going to have to download everything through Twonky Media Server and buy another drive?

Look forward to comments, thanks in advance.

You have a problem with your firmware. Something is corrupt. You need to reinstall the firmware, but since you cannot access the dashboard or SSH, then you are stuck with only one option.

Use one of the ‘Debrick’ guides from this forum. Choose one that specifically says it does not delete the data. It takes a bit of extra work and a cable, but it doesn’t take much time and you will get your MBL working with all the data.