Unable to acces folders


I am having trouble accesing different folders on my MyCloud NAS. What can I do to gain acces again to them. I had acces to them fine before so I do not know what happened and why only some folders are inaccesbile. I can acces them easyly with the desktop app but not through FTP or network SMB.

I am runngin firmware v04.03.00-405

Hi there, is the share you have the folders on public? If not, you can try to make the share public to see if after that the folders are accessible. i would also like to know what operating system you are using.

You can also try to reset the unit, this link can help you out with the reset process:


Thanks for the reply.

Unfortunetlly setting to public this share does not solve the problem.

I have the same issue using windows or OSX to acces the folders.

If I acces them using the MyCloud app I have no issues but on the local network the speed is limited so that is why I prefer to acces it like a regular NAS.

Please help.

I’ve been having the same issues, but after looking at another thread, I was able to change the permissions using Samba and Putty. My only problem now is using the instructions in the other thread, whichI’ll post at the end, I can only change permissions to one folder at a time. Any body know the command to make changes to all folders and subfolders at once? 


instead of chmod 755 folder_name us chmod -R 755 * from the top level share folder. if you are correcting owners instead of permissions use chown -R user[:group] *

if not sure then supply the steps and commands you are currently using

how did you get the files here with bad permissions  / owners?

It worked great with chmod -R 777 sharename

For some reason, when I enter  "chmod -R 777 share"  I get an error messge saying 

chmod: file mode ‘-R’ contains unrecognised permission specifier ‘R’ 

Any ideas?

I used Terminal on Mac OSX to connect via SSH to my drive. Perhaps this is why it worked for me.

Are you sure you are on the basic single drive mycloud?

there can’t be a space between the dash and the R

how are you accing the mycloud?

There is no space between the dash and R: “-R”