Unable Obtain An IP Address - Running OSX 10.7.5

I am trying to get my LiveHub to share the internet connection from my new Mac. It worked fine with my older Mac.

I am running OSX 10.7.5.

Internet via Airport.

Connecetd to LiveHub via Ethernet (SystemPrefs/Network/Ethernet is “Connecetd”.

Can see the LiveHub on my Mac and able to drag-drop files on to it.

No Firewall.

Mac Settings in SystemPrefs/Network/Ethernet:

Using DHCP

Mac’s IP address - 169.254.127.219

Subnet - 255.255.0.0

Router - Blank

DNS - Blank

Mac Settings in SystemPrefs/Network/Ethernet/Advanced:

Configure IPv4 - Using DHCP

IP address - 169.254.127.219

Subnet - 255.255.0.0

Configure IPv6 - Automatically

Everything else is blank.

System Prefs/Sharing:

Internet Sharing - On

Share Your Connection From: Airport

To Computers Using: Ethernet, Airport

LiveHub:

IP Address: 169.254.27.12

Subnet: 255.255.0.0

Gateway: 0.0.0.0

DNS: 0.0.0.0

 When I click “Automatic”, I get the error message - Unable to obtain IP address".

Tried clearing Network log-in info. When I try Check Connection, all 3 are 3 X’s.

I am totally stuck. Any help would be appreciated.

I assume that live hub IP address is really 169.254.127.12 or Mac is 169.254.27.219.

No, the Hub is - 169.254.27.12

The Mac is -  169.254.55.159

Why has the Mac IP address now changed and why are they on different networks?

Have no idea. The IP address of the Mac is now: 169.254.105.191 I did not change anything. With regards to networks, how do I tell if they are on the same one (remebering that they are connected via ethernet)?

If you are on the same network the first three groups of numbers will be the same, its only the last group of numbers that will be different.

For example

Hub 169.254.27.12

Mac 169.254.27.13

OK. So do I change it manually & on which device?

I renewed the DHCP lease, so my Mac settings are now:

IP: 169.254.99.67

Subnet: 255.255.0.0

Router: Blank

DNS: 208.67.222.222   208.67.220.220

The settings on my Hub are now:

IP: Blank

Subnet: Blank

Gateway: Blank

DNS: Blank

So how do I get the coorect info on to the Hub? Tahnks in advance.

Both devices are getting 169.254 because they’re both using DHCP and *NOTHING* on your network is providing addresses.

You need to have a router (or some other device) on your network to manage DHCP for your entire network.

Tony,

The OP says he is using AirPort.  I think that is the name of the Apple router.

Yeah, but it’s unclear if the WD is connected to the airport, or if he is trying to connect it directly to the Mac’s Ethernet port.

If the WD is connected directly to the Mac, then the Mac and WD will both need static IPs, not DHCP.

Got it!

I  have the Mac connected to the internet via AirPort. The WD Hub is connected to the Mac via ethernet . Both Airport & ethernet were set-up using DHCO on my orevious Mac. It was working just fine on my other Mac this way, that is why I am stumped. 

CoBrit66 wrote:

It was working just fine on my other Mac this way, that is why I am stumped.  

I don’t know how it could have been…  That’s an invalid configuration.

Both the WDTV and the Mac are expecting there to be a DHCP server somewhere out the (wired) ethernet ports, and no server exists.   So, of course it’s going to tell you that it can’t find an IP address; there’s nothing out there providing one.

OK. So based on th following config:

Mac connected to internet via Airport (wifi).

WD Hub connecetd to the Mac via Ethernet.

Manual set-up on Mac & WD Hub.

I am asked for the following (Mac):

Config IPv4: Manually

IP Address: 

Subnet Mask: 

Router: 

DNS Server: 208.67.222.222   208.67.220.220  

Search Domains

I am asked for the following (WD Hub):

IP Address: 

Subnet Mask: 

Gateway: 

DNS: 

s you can see, most are blank as I have no diea what to put in there.

Thanks,

J

Why aren’t you connecting them both to the airport?

“Dumb question” is in quotes!  Duh.  Connect your devices in the ethernet connections of the router/AirPort.

Fair question. I use Airport to connect to WIFI services (I am on the road a lot). So I can only connect from 1 device at a time,

""Connect your devices in the ethernet connections of the router/AirPort. "  Not sure what you mean.

Which AirPort do you have?

It is just an airport card, no base station.