UI Hang

I have a 8TB Sharespace NAS. I was copying files from a USB connected drive to another NAS when I lost USB connectivity. I went into the HTML UI and saw that an update was needed so downloaded and started that update. The UI went to the progress page and nothing happened there for over 10 hours. I finally quit that and now everytime I go back to the UI and log in it goes to the progress page. I have tried to power the drive down with the front power switch and reset it with the rear reset button and neither will do anything to the drive, it stays powered up. The drive is still working other than the UI hand and the USB failure so I’m concerned about just unplugging it. Any ideas? I’ve had an email to WD support for a week and no response.

It is provable that the firmware update did not installed correctly. Try using another web browser, or connecting the sharespace directly to the computer, if that doesn’t work, backup the important files and then disconnect the sharespace power cable for 1 minute, and check if that helps. 

I’ve tried Firefox, Chrome and Safari all work (don’t work) the same. I haven’t tried connected directly to my computer but can. There is over 2TB of data and 200,000+ files that are all important and they are currently backed up but it took over a week to do all those copies. I was planning to power cycle but I think it is absurd that a RAID drive is so fragile. I already had to pay over $3000 to recover the files lost by this dirve once.