uEFI GPT Hotfix available

Microsoft has released a hotfix to allow support for computers with an EFI partition.  Many computers shipped in 2013 use this.

If you are getting an error trying to backup a new computer this may well be it.  Click or press Windows(key) and type diskmgmt.msc and press enter.  If you have a small partition at the front of your drive that says EFI, you will need this hotfix.

Download the hotfix, run it ion the server and it will update all the client connectors.  Reboots of the clients is helpful.

Please book mark the link or print out the notes, as you will encounter these issue if you do a Bare Metal Restore at a later date.  It works fine.  This is just to plant the seed when you get the funky errors, you will remember, oh yea, Gramps said this would happen :slight_smile:

Added 9-14-2014   

After the server reboots from installing this hot fix, do a Windows update to get another patch.



Thanks for the hotfix, Gramps.

wow doing this broke all my current backups.  Server cant see any of the computers (besieds the one windows 8 comp the hotfix was added for) even after the launchpad updated, or was uninstalled/reinstlled on client computer.  When trying to restore files the software just sits at 12%. 

Be leary about going this route.

When you install this hotfix it also updates all the clients.  They need a reboot

Just read farther, if you unistalled.reinstalled from the servername/connect the client should show online.  Did you reinstall from an old saved copy of the connector from disc?

All of the clients are updated, the issue is if i try to open a computers volume it just sits at 12% if it was before the hotfix was applied, all the backups after open without issues.  Going forward this should be fine, but if anyone needs to rollback a file or computer to last week it may become an issue.  I dont see that happening but who knows.  I’m going to try to do a bare metal restore of a volume before and after the hotfix just to see if that can be done.

Well dunno.  You should not be having an issue with previous backups.  I doubt BMR will behave any differently.  All of the clients do this or just one in particular?

My only thoughts arew to run a backup database cleanup.  I don’t suppose you know for sure that a backup opened right before you did the update do you?

I didnt try all the clients but i did try 4 and all of them did the same thing.  everything after the hotfix works fine on all 4 of thoes clients.  Going forward i dont see this as an issue, but for someone who is just applying this fix they might want to make sure noone is going to need anything prior to that.

How do i run a database cleanup? 


on the right bottom pane is more backup tasks>tools

As the warning tells you, if there are errors you may lose some backups.  But if you lose some, they more than likely would not have worked anyway.

We are getting quite a way into 2014 and there have been quite a few updates for various MS software products, both server and client. The hotfix is dated February 2013.

So is this hotfix still required?

I’m seeing the same type of error and I’m on Windows 8.1 on a domain joined tablet which I have managed to get the client onto at last…so some updates have been rolled out.

I am unable to do backups to a DX4000, presumably because of the EFI partition, even if I cut the backup down to volatile folders on the C drive.

Is this the same problem?



Yes if it is uEFI you have to have the hotfix. I think they do not include it in a rollup as it changes the database and has noteable notes if you uninstall it.

A new “patch” is required if you install the uEFI hotfix.  After the server reboots from this install, go to windows updates and check for updates.


1 Like


I am IT guy at a small firm. We bought  WD Sentinel DX4000 with windows 2008 R2. I had faced the issue with GPT or UEFI based systems. I have installed the Hotfix and the updates are all done. No new update is in the Windows update.

For a week the systems were backing up fine but now I am facing problem again. Several systems are showing offline in the “Computers and Backup” List. Even on client side I cant sign in. It says server is offline and on server side it says the client is offline. I did a ping test and all clients can access the ip of the server. By server ofcoarse I mean WD Sentinel DX4000.

Can you Help?


Ahmad Jawad

Rebooted everything, server and clients?  Some online and some off sounds like a version mismatch of the clients.


Found the problem at client side.

Some of related server services were off on client Laptops. Had to start them manually. I will have to moniter them regularly.

anyways thanks for the help. 


Ahmad Jawad


Check the date on the server also.