UEFI does not detect WD2003FZEX and crashes

I have a problem with a WD2003FZEX (WD Black 2TB) drive that is not detected on an Asrock 970m pro3 at boot. Worked without any problems for over a year. The UEFI tries to access the drive but crashes. It detects other drives just fine. I tried to following:

  • Changed the SATA port on the mainboard, doesn’t work
  • Changed the SATA cable, doesn’t work
  • Changed the WD Black drive with a 1TB WD Blue which is detected without any problems (so the mainboard is okay?)
  • Connected the WB Black to a different computer, drive works fine and SMART is ok, passed WD Life Guard checks
    But the WD2003FZEX (WD Black 2TB) drive is still not detected by the Asrock 970m pro3. I did a Google research and found a website of a data recovery service who claim that these symptoms are caused by a firmware issue. The solution is to update the drive’s internal firmware. Can I get a confirmation on that? Where can I download a tool to update the firmware? All I found is software for external drives. Or should I RMA that drive?

Thanks in advance!

At this moment there are no firmware update files available for the WD Black hard drive. I’d recommend replacing the unit under warranty.