U-Verse Residential Gateway - how to get My Book World Edition (whitelight) working on it?

I recently moved my Internet access at home from a Comcast cable modem to ATT U-verse (including TV and wireless Internet). I had my WD My Book World Edition (MBWE)  working fine with Comcast, and I assumed I would be able to use it similarly with ATT U-verse, but I’m having problems. The Internet connection from ATT U-verse is via a 2Wire 3800HGV-B residential gateway (2Wire). When I hook up the MBWE to the 2Wire gateway (using the same coax cable I used with Comcast), my PC (WinXP) can’t find it on the network (using the WD Discovery app). 

Anyone have any ideas what I can do? I use the MBWE for wireless backup of our home computers, as well as a general file server.

I thought I saw somewhere that the 2Wire gateway doesn’t support home networking?

Any thoughts, ideas, fixes, etc. would be greatly appreciated!!  (Note, I’m not super technical, but I have some knowledge of networks…)

Thanks!

UPDATE

I have now been able to see the MBWE and map drives to it by putting my PC into “DMZplus” mode (e.g. putting my PC into the DMZ). The reason I tried this was this note I found that talked about the lack of UPnP support in the 2Wire gateway ( http://www.broadbandreports.com/forum/remark,25239849?hilite=upnp+dmz).

The challenge is that, while I CAN get a connection, it is INCREDIBLY slow, and unusable for file backup or storage.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en

Regards,