Twonky wont read files on WDTV Live Hub

I have the following:

2 windows 7 PCs

Netgear N-300 router

WDTV Live Hub

All devices are on the same network.  WDTV is wired to the router.  PCs are wireless.  The windows 7 computers share a Homegroup, and can see the WDTV Live Hub on the network.  WDTV has no problem accessing the internet or the PCs.  The Twonky server registers the two PCs as Media Receivers, but does not register the WDTV, and cannot read files from the WDTV.  I’ve manually added the WDTV to the Twonky list of Receivers, but Twonky still does not read the files.

I recently installed the router, as well as 1 new W-7 PC, replacing an old XP PC and old router.  Twonky worked fine before the change.

Any suggestions for why Twonky is not able to read the WDTV?

On what device are you running Twonky, one of your PCs or the Hub?


Also, forgot to mention that turning off firewalls and antivirus does nothing.

I’m not understanding.

WHAT twonky doesn’t see your WDTV Live Hub?

The Twonky instance that runs ON the WDTV Live Hub is not SUPPOSED to see ITSELF as a server.

In other words, you can’t go into the HUB, select MEDIA SERVERS, and then Select the HUB again.   

It doesn’t work that way, and doesn’t need to.  It’d be redundant.   Since all the files are already on the local HD, you don’t need to use Twonky to access them.

Is that what you’re trying to do, or did I miss the boat?

No, the Twonky Server should be cataloging the files on the WDTV, then allowing streaming to other devices on the network (at least that’s my understanding).  I can’t stream to my PCs because there are no files identified on the Twonky Server  (http:// ip address of WDTV Hub:9000).  Does that make sense?

I think you ar seriosly confused about how this all works.

The Twonky Server catalogs the media files then broadcasts to other DLNA media players that it can serve the media streams.

If the other devices don’t understand DLNA or UPNP then you are not going to see any of the media files.

Well put.  Twonky is not categorizing the files on the WDTV Hub.  Why not?

Have you turned it on? It is not on by default.

Yes sir.  Twonky is enabled.

It takes a little time for Twonky to find the files.

Go into the SHARING section of Twonky Setup and make sure the checkmark is checked next to BOTH Content Location boxes.  One box is BLANK, and the other is just a forward slash.  (/)

Make sure the RESCAN INTERVAL is “-1” which means it should start re-scanning as soon as it detects new files.

Last, go to the MAINTENANCE menu and try RESTART / RESCAN / REBUILD as necessary.

Now some questions.

Do the other UPnP / DLNA devices even see the Hub?   If NO, then exactly what are these other devices? 

If yes, and none of the above helps, then it’s possible Twonky doesn’t support the files you’re trying to share.

In the SERVER STATUS tab, what are the counts for each of the media types?

Hi all. I’m getting the same issue. The WDTV Live Hub’s Twonky service is up and running. But I still cannot select the “shared folders” on the hub’s internal drive in the Twonky configuration’s home page. In “browse” there’s a root directory (/) followed by various other directories. I tried them all and non of them show an obvious shared folder to point to. Or do I leave it set to root? No media counts. Tried restarts, rebuilds etc. Any ideas?

By comparison my (NAS) WD My Book World 2’s very similar Twonkey configuration’s home page allows you to pick the shared “Public” folder share from “Browse”. This is set up with the drive’s Discovery configuration/shares tab as you know. 

And why can’t I do the same with the hub’s Discovery browser configuration path? I can’t see where I can make new drive shares like in the NAS. Ultimately I trying to connect my Samsung Galaxy S2 phone to the hub and stream using PlugPlayer. Anybody?


You can’t have Twonky stream from NETWORK drives.    It can only stream from the internal or USB drives.

Hi. Yes…stream from the internal 1TB drive or USB to the smart phone like I can currently do with my WD MBW2 NAS drive with PlugPlayer. Except I can’t set the shares in the Hub’s Twonky like I can in the NAS Twonky as I said ealier. Or have I got this wrong? The phone can “see” the Hub’s Twonky server but no shares.

And any ideas on setting up new shares on the hub?


Well, if you leave it as ROOT (/), then it should share ALL video present on the INTERNAL drive.

If you want to only share a SPECIFIC FOLDER, then you do this:

Go to the Twonky ADMIN webpage.



On the “/” entry, click BROWSE.

Start at LOCAL, and browse to the path you want to share.  Select it.

I think you’ll have to UNCHECK the “BLANK” line.

Ok I’ll give it another go later.

Sorry to push this but any ideas on how to add a share as earlier?

Many thanks in advance.

 Sorry to push this but any ideas on how to add a share as earlier?

That’s what I explained in the prior post.

Sorry that’s probably the way I put that…what I mean is how do I create a new share on the internal drive aside from the existing ones? In the WD MBW 2 web browser there is a page to add, create and name new shares which Twonky then “sees” in its “browse” pop down. Apologies if I’m still misunderstanding you.




On the Hub, you cannot do that.

There’s only ONE Network share:


You cannot add additional or separate network shares.

Ok that explains it. Now at least I know I’m not going mad!!!

Many thanks,