Twonky v5 pretty bad (as opposed to v4)


#1

Is anyone else here using the WD TV Live with Twonky Media Server v5?

I was happily using TwonkyMediaServer 4.4.17, but now updated to 5.1.2 (tied into the firmware update of my NAS), and now everything is a mess. :(

  1. Regardless whether I select Video, Music or Pictures on the WD TV Live, I am always presented with the same tree, who has again the three choices Video, Music and Pictures at the top-level again. So I always have to choose twice, and the first choice in the WD TV Live main menu has no effect whatsoever any more. The remaining tree is then always the same.
  2. I am now entirely unable to play all songs of single genre. I can still play all the songs of ONE artist in ONE genre, but not ALL artists in ONE genre. I guess this is due to the WD TV Live only playing the contents at the current node of the tree, but never anything contained in subdirectories.
  3. No more internet radio through .m3u playlists. (Well, let us hope that this comes as direct feature to the WD TV Live in the future.)

So the update to v5 made using the WD TV Live with TMS pretty painful, despite TMS recognising the WD TV Live by its name now, whereas with v4 it was pretty fine.

Anyone else made the same experience?

Any remedies?


#2

I have the same config except a QNAP 419p and 3 WD TV Lives with 1.01.24.  

I have not had quite the same experience but since the firmware and twonky upgrade I  now cannot connect to the twonky media server.  The Twonky server is found by the TV Live and you appear to connect but with about 2-3 seconds there is an error “THERE WAS A PROBLEM CONNECTING TO THE NETWORK THE DEVICE COULD NOT CONNECT TO THE NETWORK” and it kicks you back to the main menu.

 I can connect to the NAS via the network path and in folder management on the WD TV and can also connect to youtube so the network connectivity of the device is fine.  

I can also connect to the Twonky server view XBMC DMP on my MAC with no issues at all so it looks like an interconnect issue with these two devices.

Prior to the upgrade everything worked pretty well.


#3

I accidentally updated my WD TV Live now, but I have still no problems connecting to Twonky v4.

So I guess your best bet is to try and report this to PacketVideo as well, the manufacturer of Twonky, though they do not seem respond very well. Let us hope that they take this more serious if they get more bug reports from several users.

On the bright side, Qnap announced in its forums recently that they are going to separate Twonky from the firmware, and offer it as a QPKG package instead, since a lot of people complained about v5 not working. That means you can stick to v4 without missing out on the firmware updates for the NAS.


#4

Anyone else any experiences with Twonky v5 to offer?

My NAS has a new upgrade that improves lots of relevant things, but I am also worried that Twonky 5.1.4 will be just as bad as the earlier Twonky 5.x.y. 

Does it still mix up video, pictures and music for the WD TV Live?


#5

Hi there,

I have a ReadyNAS Duo with firmware 4.1.7 T29 Beta, WD Live (most current firmware), plus the NAS is running TwonkyServer 5.1.3. It is setup to stream Shoutcast, photo’s, movies etc to the WDTVLIve.

The symptoms you are seeing are exactly the same as I see, for example I setup Movies to only stream in Twonky Video formatted stuff but on the WD, it shows under Movies, Photo’s and Music I believe. Basically Twonky doesn’t take any notice of what format you give it to stream, you see all folders and all formats. The same problem is seen also on using the ReadyNAS Duo 4.1.7 T29 DNLA .17 release also I believe but it gets the thumbnails right while Twonky duplicates .jpg’s and movies also - annoying. Basically it makes Townky useless until v6 comes out.

I don’t stream music (beyond radio) but that works okay it seems on the Twonky 5.1.3 release but didn’t in the 5.1.2 release.

Hope that helps, not ideal by any stretch of the imagination and frustrating for the money.


#6

matthewg wrote:> I don’t stream music (beyond radio) but that works okay it seems on the Twonky 5.1.3 release but didn’t in the 5.1.2 release.

 

Hope that helps, not ideal by any stretch of the imagination and frustrating for the money.

 

 

Thanks for your informative reply! So do I understand correctly that Internet Radio via .m3u playlists works again since v5.1.3?


#7

I know it works, but instead of giving you a definitive answer that is wrong, I’ll check tonight. The reason for my diligence is that I’ve changed two things, the beta firmwarre of ReadyNas to 4.1.7 and Twonky to 5.1.3, and both support radio streaming, so I’ll check Twonky tonight and get back to you.


#8

Thanks! That is very kind of you! :smiley:


#9

It seems that using Twonky 5.1.3 (on ReadyNas 4.1.7 Beta T29) to my WDTV Live 1.2.21, the radio channels seem to be ‘inconsistent’. About 50% of the radio channels in Shoutcast work and slightly less in the other radio channel method (forgot the name), but I don’t seem to be able to open .m3u files directly from my WDTV Live, I just see the channels which I assume are playlists.

Decifering these into whether some are .m3u and some are some other format, I don’t know how to do that. So if you can let me know, I’ll have a look. Or if you want me to check specific radio channels, I’ll do so on 5.1.3.

Cheers.


#10

Here is an example radio playlist of mine, that works fine with Twonky v4 and the WD TV Live. It is just a text file with the ending “.m3u” having the following content:

#EXTM3U

#EXTINF:-1,HR3 MP3 Stream
http://metafiles.gl-systemhaus.de/hr/hr3_2.m3u

#EXTINF:-1,HR4 MP3 Stream
http://metafiles.gl-systemhaus.de/hr/hr4_2.m3u

#EXTINF:-1,HR1 MP3 Stream
http://metafiles.gl-systemhaus.de/hr/hr1_2.m3u

#EXTINF:-1,HR Info
http://metafiles.gl-systemhaus.de/hr/hrinfo_2.m3u

#EXTINF:-1,HR2 Kultur MP3 Stream
http://metafiles.gl-systemhaus.de/hr/hr2_2.m3u

(It is just a list of the public broadcasting channels of Hessen, a state of Germany.)

This .m3u-file is contained in any subdirectory of the music directory that Twonky monitors. Its position has no effect, i.e.  when the WD TV Live connects to Twonky v4,the playlist is then available under “Internet Radio”, but not under “Playlists”, where all the other playlists are found.