Twonky stop working after update. Need Help

Guys, Hello! Sorry for My English, I hope you’ll help me.

I became the happy owner of WD MyCloud 2TB
However, after several days of use I noticed that music in WD sorts alphabetically. I have learned that it is possible to fix in two ways:

  1. Change the configuration of xml-view
  2. Or Update Twonky to version 8.

The first method for some reason did not work. And I tried to update Twonky

I download the package from
and installed according to the instructions (

/etc/init.d/twonky stop
cd / usr / local /
mv twonkymedia-7 twonky7old
mkdir twonkymedia-8
cd twonkymedia-8
mv /usr/local/sbin/ /usr/local/sbin/
mv twonkystarter twonkymedia

But then Twonky didn’t work. What I just did not try. And I put the previous version and used the other instructions. But all in vain. I tried tdifferent commands

/usr/local/twonkymedia-7 (-8)/twonkystarter start
/usr/local/twonkymedia-7(-8)/ start
chmod +x twonky (proxytwonky, twonkystarter)
./twonky start

It either did not work or write that “binary file not executable”

Factory reset of WD will help in this case? How can I back it to work state.

Win7, WD MyCloud 2TB, Marrantz NA8005

Sorry for my english, I hope you can help me)

MyCloud doesn’t use a PowerPC architecture processor; it uses an ARM architecture. So you have downloaded the wrong image.

You might try scrolling to the bottom of the downloads list, and using:

or the v2 or v3 images, as appropriate for your firmware.

I’d be interested in how you get on, and if you have any licence issues; I have never tried upgrading ( note the twonkyforum comment “For all versions – PC as well as embedded – you will need to purchase a license from our online store to run them beyond the trial period”). There’s some discussion of where twonky should be placed, and how to restart it here:

To sort out your mess, you could downgrade your firmware, then upgrade it again: search the forum for ‘downgrade’. You might even be able to get it to simply re-install the existing software by using the downgrade trick of changing the version string.

1 Like

Thank you so much!
I am inattentive, I did not see the necessary package. Thanks, I’ll try it.
After the expiration of the trial period I purchase a full license.
Thanks for the help!

Thank You!
It worked for me

That’s good news!

Did you have to change any of the instructions you gave in your first post?
Did you have to change any file locations from the MyBook instructions to suit the MyCloud?

Here you can find all the instructions for updating to TwonkyServer 8:


Probably the first thing you needed to know before you embarked on your ill-advised “fix” is how music is streamed from a DLNA media server, and it is that music tracks ARE streamed in alphabetical order, so the Twonky installed on the My Cloud was working fine. This is one of the issues with streaming music via DLNA.

Also, the My Cloud device is not only a media server, it is also a network shared device, and when music tracks are streamed via this second method, they ARE in track order. The My Cloud app streams music as shares and in track order.

When music is streamed to a mobile device, most apps stream it as coming from a DLNA media server, (Although most iOS apps stream music from shares in track order) I do know of (and use) one Android DLNA app called Bubble/UPnP that can stream music via both methods. If one goes into a music album folder using this app, music can be streamed in track order as if coming from a shared drive.

Good luck getting your My Cloud’s Twonky working again, I have no idea how to clean up that mess.

I deleted the folder of Twonky for MyBook and install the new one for MyCloud Firmware and it worked fine. Everything was easy. Honestly I thought that there will be problems.
Now I have a trial period of Twonky and all my media library in right order, but I’m going to purchase it.
Thank You Very Much!