Twonky not working after OS5 upgrade


Updated from OS3 to OS5, installed the Twonky app to put back by DNLA service but it will not run, I cannot connect to it via TV etc nor can I connect to it via web, the service simply isnt there
This is whats installed

This is what i get when i click on configure

I’ve tried everything that I have found when searching on the net, re-installed Twonky manually using SSH, can’t seem to downgrade it back either so it’s a useless box to me at the moment.

Anyone any ideas on how to get Twonky working.

Probably a dumb question, but have you tried restarting your My Cloud to see if the Twonky app will load on device boot?

Probably doesn’t apply to the OS5 version of Twonky, but as a troubleshooting step see if you can access the Twonky administration interface like one could do in OS3. Exampe: http://wdmycloud:9000 or by appending :9000 to the My Cloud’s IP address in your web browser.

Do you have Windows or Mac? Below image is from my WD MY CLOUD TWO that has OS5. I have Windows 10. Click on, tap or activate image to enlarge it.


Yep, tried rebooting. The twonky service will start briefly then stop and will not restart. OS5 is so bad, everything worked just fine in OS3 :frowning:


yeah im on windows 10 but I dont see my wd anymore as the twonky service wont run, i only see it as a storage device and a “computer” device. It used to appear as a media devoice when it was running OS3

While WD claims one cannot downgrade back to OS3 once upgraded to OS5, customers/users have found ways to do so. If you want to try and downgrade, use the forum search feature (magnifying glass icon upper right) and search for a number of past discussions on possible downgrade back to OS3 methods.

One example past discussion where someone downgraded back to OS3 on a second generation single bay My Cloud.

1 Like

Awesome stuff, took may hours but using the link you gave I managed to rebuild my disk and get OS3 back on it. Even managed to recover the 2tb of data from the drive before hand which was a bonus. Many thanks for the nudge in the right direction.

Yet another sufferer from the upgrade to OS5. I have in total 9 My Clouds, a mixture of Gen 1 and Gen 2 ranging from 3TB to 8TB. So far I have 2 (6 and 8TB) My Clouds rendered useless by the upgrade. I have tried to revert to OS3 on the 6TB one, bricked it and have now scavenged the HDD for use elsewhere. The only real solution to this is for WD to sort out the clash between OS5 and Twonky and issue another upgrade - or even re-badge OS3 as OS6 so that it can be installed as a normal update for those in difficultties. Incidentally, I have tried replacing Twonky with Emby (won’t play mkv) and Plex (uses too much of My Cloud’s capabilities). Is this an attempt to push us into buying the poorly reviewed My Cloud Home?

Have you contacted Twonky or seen their support forum for help with their product?

WD indicates among other things about Third Party Apps like Twonky, the following.

My Cloud OS 5: 3rd Party Apps Matrix


  • Western Digital Technical Support does not provide setup, configuration or troubleshooting of 3rd party apps outside of the download, installation and successful launch of the app from the My Cloud dashboard.
  • 3rd party apps are supported by the app vendor.

One may need to remove Twonky, delete the left over database files, then reinstall Twonky. See Delete Database and Configuration Files in the following WD Knowledge base Article on Twonky Server Configuration and Settings.

My Cloud OS 5: Twonky Server Configuration and Settings

My Cloud OS 5: How To Install 3rd Party Apps

Thank you, Bennor, for your helpful suggestions. I had, in fact, followed the instructions provided by WD for the re-installation of Twonky after the upgrade to OS5 - several times - but had not used SSH to apply the commands given to clean out previous Twonky configuration files. I have now also done this, apparently invalidating any warranty. I have not contacted Twonky because 1) the problem was caused by WD’s firmware upgrade and 2) WD’s matrix shows that Twonky is compatible with OS5 (your first link). However, I do note that on Twonky’s site it appears not to specifically offer a download for OS5, just previous firmwares. That said, when WD urged everyone to upgrade to OS5 their instruction was simply to install Twonky from the list of available apps without any complex configuration.
Having followed all the steps you kindly detailed, Twonky is now operating normally, with the exception that Windows 10 explorer shows a new entry, ‘Twonky NMC Queue handler’ under the ‘Network’ tab. This is as happened previously, and Twonky failed after a few days. I could sometimes recover it by uninstalling it, rebooting My Cloud and reinstalling. Time will tell if it is now stable.
I still feel that WD has let down their customers with this update and should be doing more to mitigate its effects. It is obvious from many anguished requests for help online that I am far from alone.