Twonky Media server reduces resolution on photos - how can I fix this?

I am using a Western Digital My Book World Edition II (WDH2NC20000N) along with a Denon AVR-3310CI receiver.  Twonky Media server (version 5.1?) came pre-installed.

Everything works great for audio.  For photos, I have no problem acessing photos stored on the MyBook NAS,  however, Twonky Media server reduces the resolution of the photos when displaying them through my receiver.

Twonky Media server does show the photos correctly (800x600 resolution) through the web browser on my PC.

This is not a limitation of the Denon receiver, as it will properly display the same photos at full resolution from

my Win7 laptop using Roxio media server.  Also, I have seen complaints of Twonky downresolution on other forums.

Can anyone tell me how to tweak the Twonky settings to fix this?

Correction to my original post.  The original photo is actually 2048 x 1536, so we are getting a down-res even on the web browser.  I still suspect that I am getting further down-res to the Denon receiver as I expect 800-600 would still look OK on my big screen TV.

Hi Joe,

Sorry to hear that you’re having problems. Can you please check the Media Receivers section of the Server Setting browser page and see if TwonkyServer is correctly identifying your Denon? Let me know if you’re not sure how to do this?

  • Rick

Yes - it correctly identifies the receiver as a Denon.  I should have mentioned that in my original post.

Hi Joe,

I think you may be able to fix this by either selecting a different client profile, or by modifying the client.db file. I’ve asked our engineers to make a suggestion, and will post their response here as soon as I receive it.

  • Rick

Thanks Rick!  I appreciate your efforts to find a solution!

I have also noticed that Twonky will reduce the resolution of images when viewing them on my PS3. It is also recognized properly in the media server list. This occurs using a wired or wireless connected PS3 as well.

Any update on a possible fix?

Rick also responded to me on a Twonky server forum ( http://www.twonkyforum.com/viewtopic.php?f=2&t=8615&sid=88c1f4c6b03eacfb1484e1406a426a9b).  He says that if a fix is possible it might require firmware upgrade on the World Book.  He has created a support ticket so an engineer can look into this and said that I can check on the status of this issue in a few weeks.

I hope that Twonky can fix this and the WD will post a firmware upgrade.  It will be a real disappointment if I can’t use the World Book as a photo server.

Thanks for the update Joe… I appreciate your response in regards to when the new firmware will be updated! lulz

An update for you.  The folks at twonky suggested change to the clients.db file as a possible solution.  I tried the change that they suggested, but unfortunately, that did not work. 

Even more unfortunate is that the folks at Twonky only have older Denon receivers that were designed to stream music, but not photos.  As a result, their engineers were not able to pursue the problem further.  Apparently, they are unable to come up with the $600 to buy a Denon AVR-3310CI on Amazon.com :frowning:

I actually have some sympathy, in that I understand that it is not possible to go out and purchase every AV product on the planet to deal with compatibility issues, but it is very frustrating nonetheless.

I’ve got the problem fixed for my Denon.  On another forum, I found a post that said that editing Twonky’s “clients.db” file and inserting the line “XM:NOTRPICS” in the part of “clients.db” devoted to your device might work.

In the header area of the clients.db file, it explains that the “XM:NOTRPICS” instruction means to “give only original pictures, no transcoded pictures”.

I added that line to the end of the “Denon” section of the file (see below).

notrpics.jpg(

I suspect that’s what you need to do to the PS3 section (below is what the PS3 section looks like).

ps3.jpg\

I hope this helps you!

Hi, all!

I struggle with the same issue since August!! 

Streaming of videos to PC or to my TV (Philips 42PFL7665H) work perfect so far. HOWEVER, my JPEG pictures (format 3008x2000 pixel) and other resolution pictures are SCALED and show up with only 160x120 Pixel or similar small resolution on my TV.

WD Service refused to solve this isse as they feel not responsible for the Media SW on their product…

I found that is might be a solution to modify the “clients.db” file!

However, I have no clue HOW to access and modify this file from my WINDOWS VISTA PC!

Following the idea listed on wikidot.com, I already ENABLED SSH in my Network Storage Manager, however, I can not find a way to log on as ROOT… follwing their ideas to the end.

Can somebody help me to find a way to find, access and modify the clients.db form my WINDOWS PC??

Thanks in advance!
Peter

Dowload a program called puTTY at: http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

Run puTTY.  You will need to know the IP address for your MBWE.  Login as “root”.  Password is “welc0me”.

You will find yourself at a unix command prompt - very similar to an old DOS command prompt.  You will need to navigate to the correct directory by typing the following commands:

cd …

cd twonky

cd resources

You are now in the twonky resources folder.  Before editing your clients.db file, I suggest you make a copy of the file, as follows:

cp clients.db clients-old.db

You now have a back-up of your clients.db file called clients-old.db

Now you can go in and edit your file using the vi text editor, as follows:

vi clients.db

Vi is an old crappy text editor.  Instructions on how to use it can be found at: https://engineering.purdue.edu/ECN/Support/KB/Docs/ViTextEditorTutorial

I hope this helps.

1 Like

For some reason, the link to the web site with the instructions on the vi text editor can’t be seen well on my previous post.  Here it is once more:

Now you can go in and edit your file using the vi text editor, as follows:

vi clients.db

Vi is an old crappy text editor.  Instructions on how to use it can be found at:

https://engineering.purdue.edu/ECN/Support/KB/Docs​/ViTextEditorTutorial

 

I hope this helps.

Thank you for the great help!

Based on your set of infos, I know HOW to access and modify the clients.db file.

I will try to fix the issue for my Philis TV, now!

Thanks again!

After you attempt this, please post again to let us know whether this fix worked for you,

i have notice this also in the ps3 and in the iphone app… its not the original file size, wo when you try to zoom it looks blurry, can anyone post a guide how to fix this on the ps3?

Instructions for the PS3 are just a few posts above.  If this fix works for you, please let people know.  I’ve only tried with my Denon receiver.

Hello, I try to run the PuTTY but there is many parameters in it. I wrote only IP address in menu Session and used the “Open” button. But the application send a message  

PuttyError

Can you help me anybody? Than you.