Twonky database not updating

i have about 700 films on my 3TB wd my book. for the last 2 years everything has been working fine and twonky has served the files out to my media players. last week it started not updating when i added a new film so i ran the rebuild DB and everything was fine.

Now i have the same issue, i have added another 5 films but this time when i try to rebuild the DB is gets to a certain directory and then seems to stay there. i have run a full test on the disk and it reports it is ok and i have removed the DB files but still have the same issue.

Can anyone offer any suggestions ?

Thanks for any help


Have you tried updating to DLNA? to see if you get better performance.

Can you tell if the directory it “hangs” at might contain recently added media?  If so, is there any possibility the media isn’t valid?   (Perhaps the database engine is hanging up trying to read something “unreadable.”)

You might try just “backing into” it by removing the recently added media and narrowing it down.