Twonky adds and then deletes all my music?

Hi there,

I’ve just got a new WD Cloud NAS which runs Twonky 7.2.9 to replace my old Buffalo NAS. I’ve copied all my music across to the new NAS and gone into Twonky and pointed it my music and told it that the directory only contains music.

Now, weird, it goes off and scans the directory, I can see it adding all the files (about 19000 odd), can browse them from the twonky web interface as it is adding them to the library.

And then, once it has added everything, it looks like it is re-scanning the library and deleting (!) every track.

I can literaly watch it go and scan and the number of tracks goes down and down till there are no tracks in the library.

I’ve tried a database rebuil on it and it still does exactly the same ???

Anyone any ideas ?


It added 19759 music files and now it’s doing this:

Version: 7.2.9
Videos: 0Songs: 14799Photos: 178
Activity Status: Not streaming
Rescan Content Folders - In Progress…
Detailed Status
Cached Memory
Last Database Update
In Progress…
[-/shares/Public/Shared Music]…
Server Uptime
0 days, 0 hours, 17 minutes, 42 seconds
Server Restart Pending
Windows Media DRM Status
Network Interfaces 00:90:A9 Big Grin3:C8:4D

Hello and welcome to the WD Community.

Have you tried running a system restore only?

Make sure that Media Serving is enabled for the share containing your music (Dashboard/Shares).

The was one of the many steps on my way to getting Twonky working.  Something had turned it off…