Two problems, syncing and certificates

#1

Hi, just wanted to introduce myself, my name is John, and I am a ok with computers until something goes wrong, and then I am just hopeless. I was hoping getting MY Clpud was going to help by putting things in one place, but its not really. I suppose it could be once I get it up and running properly. I am running Windows 10, and using Googe Chrome rowser. Both up to date.I have to say, everything was working perfectly until the change of ISP.

I am new to My Cloud, got it about a week ago. It seemed to be easy to set up, and it copied qute a few oders, with what seemed incredible speed. I have over a hundred iTunes films which were saved in hours.

I have two problems hopefully this will be the easiest to sort, I had to change my ISP a cuiple of days ago, and when I click on the WDMyCloud Icon, it opens up the UI. As soon as I click the link to log in it tells me there is a problem with the certificate, and it needs to be downloaded. Which I do, but it makes no diference. Whe I log out then back in again, I get the same message.

The second is a bit more complicated. From the bits of inormation I have read, and not understood really well. there is a problem with Qindows 10 and the folders added to the Windows Explorer. Well, There are folders scattered in different places, with nothing inside them. Plus, my Itunes tells me it can see WDMy Cloud but there is nothing in the folders.

I am pretty good at picking things up, but need a little bit o help getting there, otherwise, and as it stands, look through this orum, everything seems soo complicated.

Can somebody please help?

Thank you

John

#2

It should be noted that for some users there is a problem with Windows 10 properly viewing the My Cloud. It was introduced in the Windows 10 November update. If the My Cloud does not show up under Computer when using Windows File Explorer while using Windows 10 then see the following thread which is tacked at the top of the subforum for some possible workarounds to this particular issue.

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

If you have not already done is it is recommended one read the My Cloud User Manual (http://www.wdc.com/wdproducts/library/?id=439&type=25) which explains HOW to use the My Cloud and its various features and options.

To access the WD My Cloud Dashboard with a web browser see the following WD Support document (or read the My Cloud User Manual). One typically uses either the My Cloud name or the My Cloud IP address. For example: http://wdmycloud or http://192.168.1.2 in their web browser. Note your My Cloud IP address will be different.

http://support.wdc.com/KnowledgeBase/answer.aspx?ID=10420

#3

Hi, thank you so much or the reply. Can you tell me anything about the certificate problem? It is really annoying having that box appear everytime I start My Cloud, and I am not sure if its a good thing or bad.

John

#4

Can you just accept the Certificate when it shows up again? I am not on windows 10, but this has worked for me before and after that you never see the WD certificate again. My Windows states the the WD Certificate was not signed/verified or sent correctly … I am trying to go from memory.

#5

Hi @John_Matt

are you trying to open the UI as https://wdmycloud? This would be the reason for the certificate alert. Here, the browser will establish a secure connection to the My Cloud and asks for / receive a SSL certificate from the My Cloud. SSL certificates normally contain information about the source and can be used like a passport. SSL certifiactes need to be bought for some / a lot of money from authorzied sources to be re-confirmable.

A My Cloud cannot be equipped with approved SSL certificates as this has to be done by the owner. Therefore a My Cloud is using a so called Generic SSL certificate to establish a secured connection. This generic certificate cannot be reconfirmed which causes the alert to pop up. It’s annoying but without an approved certificate which you have signed by yourself, there is no other chance to avoid this alert.

At the end: if you are in your own hom enetwork, you don’t need to use HTTPS. Use normal HTTP and the certificate alert will not appear.

#6

ok thank you. Its funny, that never happened till I changed ISP’s but now I know I can put up with it.

Um, that is odd, I just followed that link, and that is completely new to me. I read somewhere on here that SSL might brake the system, so havent touched that. This some where else, but will take a look again, and see if its to do with SSL.

It gives you the option to install two for the system and the user have clicked on both and the next time I open WDMyCloud, it wants me to install the certificate again.

#7

And, not sure what I did, but I can now open My Cloud in WE but its not shown as a device but just as a folder which is odd.