TV Live Media Player HDD no longer recognised

I have the WD TV Live HD Media Player (MP) connected to a 3TB Seagate HDD and has worked fine for years. I attached the HDD to my PC to update it (~2 weeks ago) & when reattached to MP it no longer works (either usb port). So:

  1. MP with mem stick USB2 (Fat) works OK

  2. MP with 1.5TB Samsung HDD USB2 FAT32 works OK

  3. MP with 2TB WD HDD USB2 NTFS works OK

  4. MP with 3TB Seagate HDD USB3 NTFS not recognised any more, but works correctly with PC (Win 8.1 64bit) - no scan errors and can write & playback video files.

I then reformatted (quick format) the HDD and reloaded the media files but still not recognisedby MP (& changed usb cable to make sure). The MP starts up OK, causes the HDD to spin up but the USB device does not show on the Video tab chain (nor on any other chain) but seems otherwise operational.

MP has latest firmware Ver 1.06.43_V but I understand that this version is not recent and so must have been used when it was previously working OK with the same HDD.

So unless the MP can no longer work with USB3 HDDs but is OK with USB2 HDDs I cannot see what else can be causing the problem - any comments would be appreciated.

Welcome to the Community.

You can confirm if the issue is related to the USB 3.0 controller and backwards compatibility by forcing USB 2.0 mode. On Western Digital drives this can be accomplished by using a Micro USB 2.0 cable instead of the Micro USB 3.0 cable. However, I am not aware if Seagate drives feature a comparable configuration option.

1 Like

Thank you for the suggestion.

The micro USB 2 cable does work with the Seagate drive but the behaviour is unchanged.

The USB 3.0 operation seems to be working correctly in the HDD since the transfer speed to/ from the PC is compatible with full 3.0 operation.

I have now found that the problem was the hdd itself that must have had some form of corruption that Windows was tolerant of.

Even though the HDD showed no problems when attached to the PC (Win 8.1) and with no scan errors, and that I did a quick reformat of the drive which also did nothing to cure the problem, I found that when I forced a full reformat & reloaded some videos it then woked correctly both with the PC & the Media player.