Tv Live Hub refuses to see USB drives

I have a Tv Live Hub. It’s running I believe 3.12.13. It refuses to see external USB drives. I’ve connected my phone to it (Android 4.2.2), and I also have an external hard drive enclosure with a hard drive in it. I’ve connected both to my Mother’s computer and it sees them fine, but the WD just does not see them. I’ve tried both USB connections, and reset the device multiple times. If I go until the Disk Manager, all it shows is the internal drive. Any ideas?

I would advise you to NOT connect your phone to it. I had an experience with a USB card reader. I inserted my phones SD card in hopes of copying a video I had recorded. Bad move, the Hub totally hosed up the SD card’s directory structure turning files into folders and visa versa.


Try a USB thumb drive in the port. Place a movie on it first then plug it in. Then from the Hub’s Home menu press Video. Now you should see the Hub’s internal drive or a list. If you see a list:


The USB thumb drive should show up in that list. Move over it with the Arrow keys and press OK then finalize the selection by OKing the green arrow on the right. Now you should see your movie file.


If you don’t see a list you’re probably looking at the Hub’s internal drive: Press the RED button on your remote. The list should display.

I’ve connected thumb drives to the USB connections as well. Sometimes it will see them, but not actually let me do anything with the videos on them. I’ve even tried something as simple as an mp3 and it won’t allow me to do anything with it. I’ve even done a complete system reset (Short of formatting the hard drive) and still get the same result. I’m at all a loss.