TV cannot detect any signal when HDMI cable is used to connect TVHUB to the tv

I have been using the WD TV HUB for almost 1 month and i ran into a problem recently. When i use an HDMI cable to connect the WD HUB to the tv, my tv cannot detect any signals. But  when it is connected through HD component cable it work fine. I have tried the HDMI cable and the TV with other devices and turned out that the WD TVHUB  has a problem.

I have been looking around on the web and came across many other similar cases with the HDMI cable.

If anyone knows how to fix this, i ould appreciate the help.

You could try setting the HDMI output on the hub to something you know that your TV supports. I am not sure if this is possible when connected via component leads but you could always try the composite output. Its likely that the hub currently has auto selected for the HDMI output and there is a known problem with the negotiation between the hub and certain TV’s. This can lead to no picture being displayed.

as it turned out the solution is as simple as unplugging the TV for a min or 2 and then plugging it back will resolve the no signal problem. 

jcdenton  Are you using IE9. See here

yeah i am. trust WD. in a nutshell i solved this issue with no HDMI signal.

simply set a static ip on the wd live tv. i had problems with signal dropping anytime i connected/disconnected usb drive. static ip sorted this instantly

Really ? I can’t see why a static IP would fix an HDMI signal.

Its more like all the old style boxes had a crappy HDMI connection, have had to cut down a few HDMI connections as they were spurious to say the least, especially if you are plugging and unplugging drives.

Took me ages to work out why my mates WDTV Gen 1 would not work, especially when it worked on my TV, the HDMI cable never occured to us, till he tried component, but even then you thinK its something more complicated like a chip…ah well u live and learn.

strange I know. I tried 2 different HDMI cables on 3 x HDMI sockets on my tv. Always the same signal problem once i disconnected my USB drive. The only thing that would get the signal to pick up was to power off the

grrr this forum posting format is infuriating. anyway static ip fixed it. what made me realize was the device ALWAYS got signal when i pulled the CAT5 connection to the router and powered back up. try it !