[ Tutorial ][ SSH Method ] Downgrade v4 firmware to v3

Please Moderators this should be a “sticky”

Another (easy?) way:

Goodle drive link: https://drive.google.com/open?id=0B_6OlQ_H0PxVRXF4aFpYS2dzMEE
My mirror: http://anionix.ddns.net/WDMyCloud/

  1. Download  this script and  this arhive

  2. Unpack all to any folder (To Public, for example)

  3. Turn on SSH access in web interface.

  4. Download PuTTY for Windows (For MAC/Linux use openssh-client)

  5. Connect to “wdmycloud” (Or to IP of WDMC)

  6. User: root, Password: welc0me (zero (number) in password!)

  7. Run this:

    cd /shares/Public
    chmod a+x install.sh

  • All settings will be lost (reset to defaults).
  • But all your data will be kept.
  • Maybe need perform “quick reset” to fix “zero capacity”.
1 Like

After the downgrade I was agitated with the result as well. I was unable to access the device through the Web UI (dashboard) and SSH. I was furiously looking for a solution. Finally it seems that the issue is caused by the user management. 

What helped for me was a SYSTEM RESTORE. Resetting the device with power off.

At the same time as you plug power into the WD My Cloud device, press the Reset button
and hold for about 40 seconds. The device undergoes a system restore and powers on.

System Restore (info from another topic)

Changes all settings back to the factory default values, makes private shares
public, and returns the administrator password to none. Your content remains untouched
and intact.

Unfortunatelly you will lose your original settings and you will have to do an initial setup, but it works.

Far better then to be furious.

Kryptonit3 wrote:

The only thing keeping me from v4 is btsync not working

Btsync is not a good idea with these drives. They are already plauged with sleeping issue. btsync would keep the drive up and spinning almost all the time.

If you really wanted to use it on fw 4.x. you could put could in a request to have the user “fox_exe” recompile for fw 4.x if he hasnt done so alreadt. He has a fw 4.x repository thread here. Look it up.

Hello Kryptonit3 and warm thanks for providing the list of steps on how to downgrade v4 to v3 firmware, it was easy on my Mac as it has ssh on Terminal.app.

However, I tried finding the latest v3 firmware ever released, and it seems WD has pulled it out of the downloads list, can anyone help point to the very latest v3 firmware ever released?

I downgrade (in process, as we speak) to v03.04.01-230 (2014.04.15) but I am sure there was another release after that. Anyone can help? Warm thanks!


Per the current firmware release notes for 04.04.02-105, firmware version 03.04.01-230 was the last v3.x release, the next firmware after that was 04.00.00-607. See the following link for a listing of firmware and links to download (most) of them:


Thank you Bennor, for your quick and kind update. I am happy to have used this very latest v03.04.01-230 (2014.04.15) firmware. It’s amazing how much more snappy it was, I had forgotten about it !

After an issue of not connecting to the UI and being forced to do a “System Reset” two times (that 40sec pin insertion in the rear, second time while plugging power) I am back in v3 without losing my data, except setup parameters.

A final two questions to you Bennor or anyone else:

  1. With the previous shares being kept intact (except users being removed) is there a need to do anything via SSH and re-assign the folders/files to a specific user, something like a “chown” command?

  2. Is there a way to remove that exclamation (warning) triangle about new firmware (i.e. v4) being available? The Auto-Update is obviously switched off…!

Thanks again, everyone.

Don’t know about (1), but for (2) you can fool the device into thinking it has the most recent FW installed.

SSH into your MyCloud using Winscp or Putty, then navigate to the folder “etc”.

Once in the “etc” folder scroll down to the bottom and you will see a file called “version”.

Edit the version file and change the version name from 03.04.01-230 to 04.04.02-105 and save the file.

Of course you will have to do this every time WD issue a new FW. I suppose you could try fooling around to see if a high version like 04.05.xx-xxx would avoid the need to repeat this task. I haven’t tried it.

Just about to follow these instructions to downgrade.

My question – the admin console, Utilities, Firmware tab has a manual update option. Why is it I cannot downgrade by simply using this mechanism vs. having to go through the process detailed above?

Well, the dashboard interface will only allow you to upgrade to a higher version number. Hence the workaround methods described above.

The reason why it is not easy to downgrade using the Dashboard is due to WD putting code in that checks and blocks prior firmware versions during the upgrade process. See the following thread that explains how to edit (via SSH) the file /etc/version and change the firmware version to allow for downgrading to a prior version.


Thanks for that. Although I love learning new things, I’ve never used SSH before. So this other method might be best.


I just completed the process for the downgrade using the “easy” method. Pretty cool. Even the Dashboard works better (faster)…like it used to…

Question, via Finder on my Mac, I see WDMycloud, but when I try to connect it fails. Same thing when I try to access via the application. I also hear the drive churning away. Is it a correct assumption that the two are related. Perhaps the drive is indexing or something and therefore will not allow me to actually log in and see the files?

When the My Cloud is rebooted it may take some time to properly catalog/index all the content on the drive (if there is content on the drive).

The following WD Support documents may be helpful with the Mac Finder issue.



I figured it had something to do with indexing.

Re: finder, i am able to see WD, but just cannot log on. I’ll let it spin for a long while.

Thanks again.

I will still never update. I use PLEX running on my laptop and myCloud 4tb

Hey, I used your guide to install v3.04.01-230 and now I’m getting the zero capacity problem (dashboard just shows “-”, plus lots of other things give an error that starts with a 2, then a bunch of 0s, then a 5 (I’m not looking at it right now, unfortunately). I came here to try to fix it and it appears the script 404s. Do you have a mirror? It’s not on your “official” mirror either.

Just do reset from webgui (Not full reset!)

I wasn’t getting a webgui, it was sitting at the white led after a good 15 minutes or so. Ended up just using v4 and am waiting for the led to turn blue. Will downgrade manually after.

I presume the install was just several dd’s for the most part? I should mention I’m a fairly experienced Linux user, though not particularly with Debian (I used Ubuntu over a year ago, but that’s as close as it gets. I’m on Arch nowadays).

Yes. “Firmware” stored on HDD, so all what we need - is dd all back (rootfs, kernel and config).
Create empty file /etc/.fresh_install to rootfs for auto reset on next boot.