Turning off internet access

Hello,
I am securing my end-of-life my cloud nas.
I have disabled cloud access ok, but in settings I see that there is still internet access.
I guess I can block it in my router but is there a way of disabling this in the drive settings.
Thanks.

@jmws
In the Dashboard, Settings>Network what do you have showing?

Below is what mine is showing and I use it only on my Local network.

Thanks for the reply. That is what I would like to see, but this


is what mine looks like.

What “settings” is indicating there is still internet access? The My Cloud Dashboard?

Normally one would check the My Cloud Dashboard > Settings > General > Cloud Access section for the remote access connection status. If one wants to disable Cloud Access, then set Remote Access option to OFF. The connection status should indicate Disabled. Note: Any time one reboots or powers on the My Cloud they should double check that Remote Access is still set to OFF, sometimes it may be re-enabled when the My Cloud is rebooted/powered on.

One should, in addition to disabling Remote Access on the Dashboard Settings, also see if they can block access to their My Cloud at the router firewall level. One can perform an internet search for their router model to see if there are directions on how to block internet access to a specific local network client.

For example on Asus routers one typically has an option to block internet access for the My Cloud.

AsusBlockMyCloud

Note: When blocking access to the MY Cloud using the network router one may have to manually set the My Cloud date and time in the My Cloud Dashboard > Settings > General > Language & Clock section.

Thank you.
The settings I have changed are the following


But as you can see on my screen grab above, the network Status still says there is Internet access.
On cat0w’s screengrab above the status reads no internet access which sounds preferable.

The other settings I have changed are these
Screenshot 2022-03-07 170715

The My Cloud tries to access the internet for other things besides Remote Access/Cloud Access. This includes NTP to set the My Cloud’s time, and the My Cloud tries to check WD servers for firmware updates. The reason why cat0w screen grab shows no internet access is because they are likely blocking the My Cloud at the router/network firewall level. Mine shows the same, no internet access, when I block the My Cloud at my router:

nointernetaccess

As previously indicated, when blocked at the router firewall the My Cloud cannot check for network time so the time has to be set manually or one has to reconfigure their router/network to either run a NTP server or allow NTP traffic through the router firewall to the My Cloud. And if I try to manually check for a firmware update with the router blocking internet access to the My Cloud I get the following error:

firmwarecheck

We don’t know for certain what changes WD will introduce with their supposed firmware update they indicate will be released when they terminate OS3 support next month. They may disable all My Cloud services that access the internet or they may just block remote access/cloud access.

Thank you. That is very helpful,