Trying to remove smartware - get error firmware not up to date when it is

so i jsut got a brand new wd essential 2tb drive. im using a mac mini with snow loepar 10.6.4. i wanted to remove smartware as soon as i plugged it in. followed instructions on the website and updated my firmware. The firmware was updated to version 2.010. When i downloaded the virtual cd manager though and selected my drive, the configure now option was gryed out and below that it said “you cannot configure your wd smartware vcd with the current version of firmware on your drive. please update your drive with the latest firmware, and then configure your wd smartware vcd”. the problem is i am on the latest firmware. i tried running firmware updater again but both my firmware on drive and firmware to be downloaded are 2.0.10. im not sure how to get around this.

just to be sure here are the software versions im using:

firmware updated: 1.0.0.19

vcd manager version: 1.0.0.3

firmware on drive 2.0.10

these are the newest versions i was able to find on the WD website. please help me. i hate this smartware software.

alos note that i never installed my smartware software to begin with, as i didnt want to use the software nor have that virtual cd icon on my desktop. so i just plugged in the drive and first thing i did was update firmware and download vcd manager to remove the virtual cd.

You didn’t remove virtual CD you only hid it.

Joe

first, i dont think you read the post. i didnt get around to removing it since it gave me that firmware error.

secondly, if i have to choose between having the whole thing there constantly, or just hiding it, id take the option of hiding it atleast since wd wont give me the option of totally removing it.

does anybody have a solution to this issue? if i can’t get this done in couple of days ill end up returning the drive and getting something else.

so NOBODY else has this problem?? where is WDC support i see wdc reps answering questions here once in a while. any ideas on waht i should do??

1 Like

If you are having error issues with intalling the firmware, you may want to contact Support directly, so they can walk you through the firmware install. 

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en

No firmware installed no problem. My problem is with running virtual drive manager and it telling me my firmware isn’t supported when I select drive. The drive firmware is up to date. The first time I ran it it updated the firmware. Running it again shows me that firmware updated and I’m on most up to date firmware. So my problem isn’t firmware update it’s with virtual drive software telling me my firmware isn’t up to date when it is.

Gotcha.  How does this happen?  I mean what causes the VCD to respond?  Are you double-clicking it?

I get to the screen where it tells me to select a drive and there is a drop down box. I click the drop down and it has the drive there. I click on the drive and at the bottom where it says continue, the continue box is slightly greed out I can’t click it and below the drop down box the error is there saying my firmware is up to date. Like I said I run the firmware updater again and it says My firmware is up to date.

Yeah, you’re looking at contacting Tech Support for any further help. 

Well, just signed up to let you know my frustration…

Got a 1.5 TB WD HD today, had the same issue as above.

Called tech support, and after installing firmware 7 times, made no difference.

Was still telling me that it couldn’t configure with the current version, even though I had already installed current version.

Tech support told me to return the hard drive back to officeworks.

You can guarantee I won’t be buying another WD hard drive again.

Smartware is a waste of space, frustrating, and pointless.

I’m having the same problem. I’ve updated many WD drives to hide the confusing, annoying VCD for my clients. There is apparently something wrong with either this version of the firmware, or the VCD Manager.

As for the WD apologist, and at the risk of encouraging them further, if the box clearly stated “you will have an annoying, unwanted icon on your desktop at all times”, then people would know to avoid this type of drive.

cavenewt wrote:

I’ve updated many WD drives to hide the confusing, annoying VCD for my clients.

So, it appears as if you’re selling them drives that aren’t what they want, and then complaining about how much work it is to make the drives more like what they do want?  Why not just sell them an Elements and be done with it?  No clients breathing down your neck and no extra work on your part, and your clients will save money.  It seems like a no-brainer.

I’m still baffled by the numbers of re-sellers who complain that the encryptable drives aren’t what their clients want and their clients are complaining about the VCD.  You’d think a re-seller would know the specifics of what they’re selling and not be so stupid.  I’ve yet to hear of someone complaining about the VCD on a non-encryptable drive.  Oh wait, the non-encryptable drives don’t _ have _ a VCD.  It’s only when you pay extra for the hardware encryption that WD made the apparent mistake of thinking you wanted to be able to unlock a locked, encrypted drive.


I’m not selling them those drives. My preferred backup drive for clients IS the Elements. 


I’m only hiding (or trying to!) the VCD for clients who have bought those drives on their own.


I’m sure WD appreciates your efforts on their behalf. I AM a customer of WD, so you can focus your energy elsewhere. Please don’t put yourself to any extra work replying to this unless you have something helpful to add about the VCD Manager that is not functioning correctly.

Hey, i had the same issue, i was able to fix it by downgrading to 2.0.3 firmware allowed me to fix run the vcd manager to hide the VCD.  What a pain in the arse!

zemote wrote:

Hey, i had the same issue, i was able to fix it by downgrading to 2.0.3 firmware allowed me to fix run the vcd manager to hide the VCD.  What a pain in the arse!

How were you able to downgrade the firmware.  I wanted to disable the VCD so I updated the firmware like the website tells you to and now th VCD Manager is unable to find my drive.