Trying to get a private share to a connected USB drive working

I have connected a Seagate 1TB USB drive to the port on the back of my MyBook Live Duo NAS. If I set the share to be Public then I can see the drive contents successfully on my Windows 7 Home Premium PC. However, if I select the share as Private and give myself and the admin users read/write access, whenever I try and view the drive contents I get a message saying “Windows cannot access \MYBOOKLIVEDUO\Seagate1TB. You do not have permission to access \MYBOOKLIVEDUO\Seagate1TB. Contact your network administrator to request access.”.

I have a Windows Credential set up for connecting to \MYBOOKLIVEDUO and I am able to see my private share on the main drive. does anyone have an idea of what I am doing wrong? I’ve never had this problem with other drives.

Hello and welcome, 

Try using WDlink to map the share. Check the link below for the steps.

Mapping a drive letter on a WD Network hard drive using WD Link 

OK. I have tried mapping it to Y:.

WDLink says it is mapped but Windows Explorer fails to show the mapped Y: drive. Bizarre!

I have just tried mapping it again to the J: drive that is the default when I launch WDLink. J: now shows in Windows Explorer but when I select it I get a message box saying “Location is not available. j:\ is not accessible. Access is denied.”


Do you encounter the same issue if you try to access the USB device from the WD My Book Live Duo root instead of mapping it as a share? You are able to access the root of the unit by typing the current IP address of your WD My Book Live Duo after 2 (Two) backslash symbol on the Windows search box or Windows Explorer path.

For example, if the IP address of your unit is then the direct access to the root would be \


Yes, I get exactly the same error.