Trying to format drive - churns for 36+ hours, then fails

My WD TV Live Hub has twice failed to format (left it for c. 24 hours the first time, and 36+ hours the second time).

It has the latest firmware, and is almost brand new. Does this sound like a terminal fault for which I’ll need a replacement machine?

Some background: the only reason I want to format at all is that I’ve had a number of other problems and want to start from a clean slate!

Example problems:

  1. USB Sync from 1TB WD Elements drive fails after a few files (read error, though I think this might be a separate issue with the power management software on the Elements drive)

  2. Network Sync: in the Settings menu, the box says that everything is set up correctly for Network Sync. But then nothing actually syncs. Have tried several times.

  3. This evening, I tried playing a few different VOBs over the Network Share. Oddly, each different file I tried produced the same playback (but they are definitely different videos when played on the laptop). And the same thing happened when I tried to play a set of test VOBs copied to a USB key - every different file produced the same playback. Could this be an issue with the Media Library seeing duplicate filenames and treating them as a single file? (Would seem strange if that’s the case - as a standard DVD rip will always produce files like “VTS_01_1”…)

Does it sound like am I wasting my time reading forums/constantly resetting the drive/repeatedly rolling back to factory standard and then reinstalling the new firmware?  Does it sound to everyone that I simply have a defective piece of hardware?

Any help/advice would be much appreciated! Am tearing my hair out in frustration:angry:

Things should not be so difficult :smiley:, just replace it.